Announcement

Collapse
No announcement yet.

How do i mass prune Posts without problems ? [TOM]

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • How do i mass prune Posts without problems ? [TOM]

    Hi,
    when i mass prune Posts I can only prune app. 50 Posts not more but i have to prune about 15.000 Post. I tried to delete everything what is older then 150 Days but i get everytime
    Fatal error: Maximum execution time of 90 seconds exceeded in /home/wbc/www/forum/admin/db_mysql.php on line 150

    even if i increase the 90 Seconds to an higher it is not enough. And it is a hard work to delete 50 by 50 Postsings. Is there any posibility to get this better worked ?


    Tom

  • #2
    I haven't really had the need to mass prune posts, but what would happen if you moved the posts to a temporary forum then deleted that forum?
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Hi,
      maybe this is an idea, i try this an let you know.
      thx

      Comment


      • #4
        if that doesn't work there may be another way ..
        :: Always Back Up Forum Database + Attachments BEFORE upgrading !
        :: Nginx SPDY SSL - World Flags Demo [video results]
        :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

        Comment


        • #5
          Fatal error: Maximum execution time of 90 seconds exceeded in /home/wbc/www/forum/admin/functions.php on line 1864


          same error, no problem to move the posts, but then when i try to delete the error come.

          Comment


          • #6
            At least they're in this temporary form now. Perhaps you could now delete this forum via phpMyAdmin. Let's wait to see what eva suggests.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              first, please understand that web hosts and php have the max_execution limit to stop php scripts from taking up too much cpu resources

              so what i'm about to suggest should be used only for this problem and the file then removed.. otherwise your web host will probably kick you off for server resource abuse

              in .htaccess file placed in root of your web account place
              php_value max_execution_time 150
              after you pruned the threads remove the .htaccess file
              :: Always Back Up Forum Database + Attachments BEFORE upgrading !
              :: Nginx SPDY SSL - World Flags Demo [video results]
              :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

              Comment


              • #8
                my board stay´s on an dedicatet dual PIII 1000 with 1024 MB Ram, i incresed the execution limit to 600 sec. but still it is not enough to delete the posts. if i delete it day by day it works if i delete it 10 by 10 days i get the error.
                Last edited by Tom Dooley; Mon 19th Nov '01, 11:09am.

                Comment


                • #9
                  90 - 600 seconds not enough!!!!

                  i'm out of ideas right now.. how can any php script in vB need more than that time??

                  Tom and NYI Fan... i'm going to split this thread into 2 threads for each of your issues and handle each one separately okay
                  :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                  :: Nginx SPDY SSL - World Flags Demo [video results]
                  :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                  Comment


                  • #10
                    Originally posted by Tom Dooley
                    my board stay´s on an dedicatet dual PIII 1000 with 1024 MB Ram, i incresed the execution limit to 600 sec. but still it is not enough to delete the posts. if i delete it day by day it works if i delete it 10 by 10 days i get the error.
                    actually if you don't mind... i'd be happy to check out your php/mysql config on your server ?

                    pm me or email me at [email protected]
                    :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                    :: Nginx SPDY SSL - World Flags Demo [video results]
                    :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                    Comment


                    • #11
                      oh see here
                      http://66.33.102.178/phpinfo.php

                      Comment


                      • #12
                        Originally posted by Tom Dooley
                        oh see here
                        http://66.33.102.178/phpinfo.php
                        from that phpinfo it says your php max_execution time is = 30 seconds still not 600 ??

                        did you change it back ? or did you edit php.ini but forget to restart apache for it to take affect ?
                        :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                        :: Nginx SPDY SSL - World Flags Demo [video results]
                        :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                        Comment


                        • #13
                          no i put it back because it did not help

                          Comment


                          • #14
                            try this

                            in php.ini

                            set
                            max_execution_time = 90
                            memory_limit = 16M
                            see if that helps
                            :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                            :: Nginx SPDY SSL - World Flags Demo [video results]
                            :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                            Comment


                            • #15
                              Hi
                              i tried thsi before increased to 16 M and increased until 600 sek
                              but still if there are more tha 100 Posts zu prune i get the error. Even i tried it on other servers the same problem.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X