Announcement

Collapse
No announcement yet.

Unable to upload.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to upload.

    [sorry to post this again, but it's got no response in the mysql forum, perhaps it's better off over here]

    My host has MySQL running in safe mode and I can't get the uploads (avatars/attachments) to work. I've set the options in the admin panel and chmod'd the /tmp directory on my site to 777. Can anyone enlighten me?

    Many thanks.
    Team Phoenix Rising
    Distributed Computing Team

  • #2
    Do you have root access to this server? That's the only way you could chmod /tmp to 777. Perhaps you're actually talkng about a 'tmp' in your space. If so, leave off the beginning '/'. Or better yet, put in the full path to this directory, i.e., /home/user/tmp.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Thanks. I'll give it a shot.
      Team Phoenix Rising
      Distributed Computing Team

      Comment


      • #4
        Great, sorted. It was me being dumb and forgetting to remove the leading /

        Thanks again.
        Team Phoenix Rising
        Distributed Computing Team

        Comment


        • #5
          Glad it worked!
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            Attachmen upload probs

            My problem may be similar. I am setting up a new 2.2.1 board and everything works except for the attachment upload. I get an error message, "There has been an error with your attempt to upload the file..."

            I'm not sure what directory is being accessed. In the Admin CP options I have specified \tmp as the upload dir.

            If I turn on the "upload in safe mode" option, I get messages like this:

            Warning: Unable to create 'tmp/today.jpg': Permission denied in ./admin/functions.php on line
            1602

            I don't have easy or direct access to the server; it is under control of the ISP. Do I need to tell them something?

            Much obliged.

            Comment


            • #7
              I assume you at least have FTP access to the server?

              Comment


              • #8
                Yessir, I do have FTP access.

                Comment


                • #9
                  Go into the forums / images directory and create a new directory called
                  temp
                  CHMOD it 777.

                  Then go into the Admin CP > vBulletin Options > Upload Options and set the second option, the directory, to
                  images/temp
                  and set Safe Mode On to Yes.

                  Comment


                  • #10
                    Thanks, it worked!

                    But I am concerned about the CHMOD 777 setting. I am weak on my Unix & server knowledge, but doesn't this allow everyone to read/write/delete, etc. to that directory? What protects it from the outside world? FTP passwords?

                    Comment


                    • #11
                      Since it is a temporary directory, there should be nothing stored there and users would have to be logged in as something other than anonymous to move it to another directory.

                      At least that's how I understand it.

                      Comment


                      • #12
                        OK. My ISP dude says he has turned on all except the 'execute' permission in that temp dir (this is an NT system), and the uploads seem to work fine.

                        Let me know if there is anything wrong with this solution.

                        Thanks for your help.

                        Comment


                        • #13
                          As long as it works, there are no problems.

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X