Announcement

Collapse
No announcement yet.

Logging In As Different Person - Major Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by bira
    I should clarify, though, that if you have no-cache headers turned ON in the Admin CP options, then this addition is redundent.
    Actually that's not accurate for the reason you mentioned - proxy servers do not read the HTML and therefore can't adhere to any no-cache META tags.

    Also I believe technically this line:
    Code:
    header("Last-Modified: " . gmdate("D, d M Y H:i:s") . "GMT"); // always modified
    should be
    Code:
    header("Last-Modified: " . gmdate("D, d M Y H:i:s") . " GMT"); // always modified

    Comment


    • #17
      Originally posted by tubedogg
      Actually that's not accurate for the reason you mentioned - proxy servers do not read the HTML and therefore can't adhere to any no-cache META tags.
      Actually the No-Cache headers in the Admin CP Options are NOT HTML meta tags but rather PHP headers.

      Check out global.php:

      Code:
      if ($nocacheheaders and !$noheader) {
        // no caching
        @header("Expires: Mon, 26 Jul 1997 05:00:00 GMT");             // Date in the past
        @header("Last-Modified: " . gmdate("D, d M Y H:i:s") . "GMT"); // always modified
        @header("Cache-Control: no-cache, must-revalidate");           // HTTP/1.1
        @header("Pragma: no-cache");                                   // HTTP/1.0
      }
      And as you can see, that space before the GMT is missing in the vBulletin code as well

      Comment


      • #18
        Hmm...when was that changed? And you're right about the space GMT thing, it's wrong in the vB code as well.

        Comment


        • #19
          Kevin it's been like that since the switch to 2. I remember the first time I installed one of the stable betas, I decided to turn it on. Oh boy, did everything become slow and heavy!

          Comment


          • #20
            Useful, many thanks.

            If it helps others, I got an error with the code as cut'n'pasted from here. The code that worked is:

            PHP Code:
            header("Expires: Mon, 26 Jul 1997 05:00:00 GMT");
            header("Last-Modified: ".gmdate("D, d M Y H:i:s")." GMT");
            header("Cache-Control: no-cache, must-revalidate");
            header("Pragma: no-cache"); 
            ...I don't think it liked the spaces, for some reason.

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X