Announcement

Collapse
No announcement yet.

Question Regarding problems uploading avatars and attachments

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Question Regarding problems uploading avatars and attachments

    I feel kinda bad even asking, because I see it in several threads, but none has helped my situation yet.

    I recently moved my vbulletin to a new web hosting service on a remote server. I no longer have it on my machine. The following is what info I have concerning my hostiong environment, I will post more as I get it:

    URL to my forum: http://www.indirectv.com/vb2/upload/index.php?s=

    System FreeBSD korsar.nsk.bsgdesign.com 4.3-RELEASE FreeBSD 4.3-RELEASE #1: Sun Aug 19 18:05:40 NOVST 2001 [email protected]:/usr/obj/usr/src/sys/alf i386

    Build Date Sep 10 2001

    Configure Command './configure' '--with-apxs=apxs' '--prefix=/usr/home/kan/plesk/apache/../release/usr/local/psa/apache' 'i386--freebsd4.3' '--with-system-regex' '--with-config-file-path=/usr/local/psa/apache/conf' '--disable-debug' '--disable-pear' '--enable-sockets' '--enable-track-vars' '--without-gd' '--with-mysql=/usr/home/kan/plesk/apache/../release/dist/usr/local/psa/mysql' '--with-iodbc=/usr/home/kan/plesk/apache/../release/lib/libiodbc' '--with-imap=/usr/home/kan/plesk/apache/../release/lib/imap-cclient'

    Server API Apache

    Virtual Directory Support disabled

    Configuration File (php.ini)

    Path /usr/local/psa/apache/conf/php.ini

    ZEND_DEBUG disabled

    Thread Safety disabled

    --------------------------------------------------------

    As stated, neither I nor my users can upload avatars or attachments since the move.

    I know the files do not even make it to the database, because an inspection of my database in mysql shows no added file after the upload attempt.

    The first indication of trouble was on attempts to upload attachments (pictures) vBulletin returned error saying it was not a valid jpg gif, etc...

    After checking "allow image size checking error" in the admin CP, we eliminated the invalid file type message, and the attachment appears to upload, but then the message in the thread has usually a white box with a red x in it.

    I then proceeded to check "upload in safe mode"

    The host (StormWeb) uses Plesk ( I have seen warnings about that) and I have tried setting a temporary directory under "safe mode temp directory" and chmodded it to 777.

    I need clarification as to whether when indicating the path to the chmodded temp directory I simply identify it starting at the httpdocs directory: IE: /httpdocs/temp or do I need a verbose path from the server down to my domain IE: /usr/local/plesk/apache/vhosts/Indirectv.com/httpdocs/temp

    With everything set as I have indicated so far, attempts at uploading attachments result in a post showing up with no errors but no indication of an attachment.

    Sorry for being so winded but I figure more info can't hurt.

  • #2
    There is some code that needs to be changed. If you do a search here for attachment problems you should find it.
    JTMON

    Comment


    • #3
      http://www.vbulletin.com/forum/showt...nt+AND+problem
      JTMON

      Comment


      • #4
        JTOMN,

        Thanks for the code suggestion. Removing the code listed allowed me to get rid of the "not valid file type" error without selecting "Allow Image Size Checking Failure". So now I am simply at the point of not having avatars or attachments show up.

        I found out that yes, my host is running PHP with safe mode restrictions... so I am working toward resolving this problem using the safe mode troubleshooting suggestions. Still no luck though getting the uploads to actually get into the database.

        Comment


        • #5
          Did you also do the second part of that link I sent you adding .gif to the end of the allowable upload files? I did that + set the options to yes for upload in safe mode and it all works now. Make sure you give it a dir to upload into and chmod it 777. I have Allow Image Size Checking Failure set to yes also. I'm using a server that runs plesk also.
          JTMON

          Comment


          • #6
            As you've pointed out, there are some major problems with Plesk. As far as I know Plesk interferes with the file uploading process in vB. Do a search for 'Plesk' in these forums. Maybe someone has found a work-around, although I haven't heard of one.

            I need clarification as to whether when indicating the path to the chmodded temp directory I simply identify it starting at the httpdocs directory: IE: /httpdocs/temp or do I need a verbose path from the server down to my domain IE: /usr/local/plesk/apache/vhosts/Indirectv.com/httpdocs/temp
            I'm pretty sure the latter is the correct path.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment


            • #7
              On my server that runs plesk, I have the upload dir set to admin/tmp typed just like that and I too have the httpdocs directory
              JTMON

              Comment


              • #8
                My forum is installed right in the httpdocs folder itself. Hope that helps
                JTMON

                Comment


                • #9
                  JTMON,

                  Bingo! Now we're cooking with gas! Settingteh Directory to "admin/temp" (on my CP) did the trick with the Avatars. it seems the sticking point was I had originally typed it: "/admin/temp" .... (notice the slash at the beginning)

                  So now I have Avatars.... stay tuned for info on other file attachments....

                  Comment


                  • #10
                    WOOHOO and a bottle of Tequila!!!

                    First time I've actually been able to help someone else with vbulletin. I have a warm fuzzy feeling!!!
                    JTMON

                    Comment


                    • #11
                      Good Karma Tonight

                      Make that two bottles JTMON!

                      Your advice also fixed the attachments problem. You will be prominently mentioned in my announcements on the site as the reason it's working again!

                      Stop in and take a bow!

                      Comment


                      • #12
                        YEEHAW!!!

                        IT WORKD IT WORKD!!!!
                        JTMON

                        Comment


                        • #13
                          The best part about all this is they are releasing the new vbulletin in the next couple days and I'm sure they fixed it in the new code. Oh well, I like instant gratification
                          JTMON

                          Comment


                          • #14
                            Well, I have the same problem here but I think slightly different behaviour. First I don't run plesk or any of that stuff. On linux redhat 6.2 and php 4.05.

                            Most users can upload jpg's and gifs for avatars/attachments ok but many also get the "not a valid jpg or gif" error message. They send me their files and they are in fact valid jpgs or gifs. I open them up in photoshop and resave them and then they can upload ok usually.

                            If I set the getimagesize to yes in the admin/cp the original files which previously gave an error will then work. Problem is I get guys uploading avatars that are 400x400 so leaving this unchecked is not acceptable because of this.

                            Has anybody found out why some jpg files when uploaded give this error and others won't even though they are all jpg's? Any other way to fix without turning off the getimagesize function?

                            Is this a php code error? Is it documented? Need help as I get deluged in emails "why can't I upload my jpg, it is a valid jpg but your system says its not..."


                            Thanks...

                            marc
                            Marc
                            -------

                            Comment


                            • #15
                              mvigod, I have upgraded to 2.2.1 since posting this and I have not removed that getimagesize code but everything seems to work fine. Maybe upgrading to 2.2.2 will fix this for you.
                              JTMON

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X