Announcement

Collapse
No announcement yet.

mySQL Exploded

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • mySQL Exploded

    Everything was working fine, computer crashed, came back and saw this... http://www.the-combine.net/vbulletin

    When I try to start the mySQL service, it says "The system cannot find the path specified."
    Deyth Valkyrre
    The Combine

  • #2
    I managed to get it working somewhat by entering:

    "mysqld --basedir=c:\mysql"

    It tells me "Can't initialize InnoDB as 'innodb_data_file_path' is not set." but then it seems to be running. Although, when I try to shutdown my server it throws up errors again and when it reboots I have to do that over again.
    Deyth Valkyrre
    The Combine

    Comment


    • #3
      unfortunately i don't know much about mysql on windows or innodb tables but check out this page http://www.mysql.com/doc/I/n/InnoDB_start.html

      To use InnoDB tables you MUST specify configuration parameters in the MySQL configuration file in the [mysqld] section of the configuration file `my.cnf'. See section 4.1.2 my.cnf Option Files.

      The only required parameter to use InnoDB is innodb_data_file_path, but you should set others if you want to get a better performance.

      Suppose you have a Windows NT machine with 128 MB RAM and a single 10 GB hard disk. Below is an example of possible configuration parameters in `my.cnf' for InnoDB:

      innodb_data_file_path = ibdata1:2000M;ibdata2:2000M
      innodb_data_home_dir = c:\ibdata
      set-variable = innodb_mirrored_log_groups=1
      innodb_log_group_home_dir = c:\iblogs
      set-variable = innodb_log_files_in_group=3
      set-variable = innodb_log_file_size=30M
      set-variable = innodb_log_buffer_size=8M
      innodb_flush_log_at_trx_commit=1
      innodb_log_arch_dir = c:\iblogs
      innodb_log_archive=0
      set-variable = innodb_buffer_pool_size=80M
      set-variable = innodb_additional_mem_pool_size=10M
      set-variable = innodb_file_io_threads=4
      set-variable = innodb_lock_wait_timeout=50

      Note that data files must be < 4G, and < 2G on some file systems! The total size of data files has to be >= 10 MB. InnoDB does not create directories: you have to create them yourself.

      Suppose you have a Linux machine with 512 MB RAM and three 20 GB hard disks (at directory paths `/', `/dr2' and `/dr3'). Below is an example of possible configuration parameters in `my.cnf' for InnoDB:

      innodb_data_file_path = ibdata/ibdata1:2000M;dr2/ibdata/ibdata2:2000M
      innodb_data_home_dir = /
      set-variable = innodb_mirrored_log_groups=1
      innodb_log_group_home_dir = /dr3
      set-variable = innodb_log_files_in_group=3
      set-variable = innodb_log_file_size=50M
      set-variable = innodb_log_buffer_size=8M
      innodb_flush_log_at_trx_commit=1
      innodb_log_arch_dir = /dr3/iblogs
      innodb_log_archive=0
      set-variable = innodb_buffer_pool_size=400M
      set-variable = innodb_additional_mem_pool_size=20M
      set-variable = innodb_file_io_threads=4
      set-variable = innodb_lock_wait_timeout=50

      Note that we have placed the two data files on different disks. The reason for the name innodb_data_file_path is that you can also specify paths to your data files, and innodb_data_home_dir is just textually catenated before your data file paths, adding a possible slash or backslash in between. InnoDB will fill the tablespace formed by the data files from bottom up. In some cases it will improve the performance of the database if all data is not placed on the same physical disk. Putting log files on a different disk from data is very often beneficial for performance.
      innodb_data_file_path
      Paths to individual data files and their sizes. The full directory path to each data file is acquired by concatenating innodb_data_home_dir to the paths specified here. The file sizes are specified in megabytes, hence the 'M' after the size specification above. Do not set a file size bigger than 4000M, and on most operating systems not bigger than 2000M. InnoDB also understands the abbreviation 'G', 1G meaning 1024M. The sum of the sizes of the files must be at least 10 MB.
      :: Always Back Up Forum Database + Attachments BEFORE upgrading !
      :: Nginx SPDY SSL - World Flags Demo [video results]
      :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

      Comment


      • #4
        I don't have my.cnf
        Deyth Valkyrre
        The Combine

        Comment


        • #5
          you can create one if you have root telnet access

          just create it in /etc/my.cnf

          aso read

          http://www.mysql.com/doc/I/n/InnoDB_overview.html

          To get InnoDB to work you have to specify where the data for InnoDB tables should be stored by specifying the innodb_data_file_path option on the command line or in an MySQL option file. See section 7.5.2 InnoDB startup options. If you have configured MySQL for InnoDB but you have not specified the above option, mysqld will print at start:

          Can't initialize InnoDB as 'innodb_data_file_path' is not set
          :: Always Back Up Forum Database + Attachments BEFORE upgrading !
          :: Nginx SPDY SSL - World Flags Demo [video results]
          :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

          Comment


          • #6
            What's troubling is that it was all working an hour ago without any extra files.
            Deyth Valkyrre
            The Combine

            Comment


            • #7
              Hi,
              i made in /
              /ib
              /ib/data
              /ib/data/logs

              than i added in my.cnf

              innodb_data_file_path = ibdata:4000M
              innodb_data_home_dir = /ib
              set-variable = innodb_mirrored_log_groups=1
              innodb_log_group_home_dir = /ib/data
              set-variable = innodb_log_files_in_group=3
              set-variable = innodb_log_file_size=50M
              set-variable = innodb_log_buffer_size=8M
              innodb_flush_log_at_trx_commit=1
              innodb_log_arch_dir = /ib/data/logs
              innodb_log_archive=0
              set-variable = innodb_buffer_pool_size=600M
              set-variable = innodb_additional_mem_pool_size=30M
              set-variable = innodb_file_io_threads=4
              set-variable = innodb_lock_wait_timeout=50

              restart but still the same problem
              i have redhat 6.2 on an dual PIII1000 with 1GB Ram
              what did i wrong ?

              Comment

              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
              Working...
              X