Announcement

Collapse
No announcement yet.

SQL error in forums Admin section

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SQL error in forums Admin section

    SQL error in forums Admin section when i select "change options" it gives me this this error

    Database error in vBulletin Control Panel: Invalid SQL: SELECT settinggroupid,title,displayorder FROM settinggroup WHERE displayorder<>0 ORDER BY displayorder
    mysql error: Incorrect information in file: './admin_vb/settinggroup.frm'
    mysql error number: 1033


    any suggestions?

  • #2
    Grab repair.php from the 'extras' directory of your vBulletin zip file and upload it to your main forums directory. Run it and follow the on-screen instructions.

    Comment


    • #3
      tried the repain.php but it gives me

      Checking table settinggroup
      Table Operation Type Text
      admin_vb.settinggroup check error Incorrect information in file: './admin_vb/settinggroup.frm'
      Repairing table settinggroup
      admin_vb.settinggroup repair error Incorrect information in file: './admin_vb/settinggroup.frm'

      Comment


      • #4
        can anyone help? i can't see to backup my forums i get this

        mysqldump: Can't get CREATE TABLE for table 'settinggroup' (Incorrect information in file: './admin_vb/settinggroup.frm')

        Comment


        • #5
          check here http://www.mysql.com/doc/C/o/Corrupt...AM_tables.html

          what version of mysql do you have ?

          try doing a myisamchk repair via telnet -> http://i4net.tv/marticle/get.php?act...le&articleid=7
          :: Always Back Up Forum Database + Attachments BEFORE upgrading !
          :: Nginx SPDY SSL - World Flags Demo [video results]
          :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

          Comment


          • #6
            well thre repair table settinggroup; give me an error

            as for the doing a myisamchk repair via telnet i can't turn my forums off. that is the original problem i can't access the option in the admin section to turn off the forums.

            what does settinggroup do? could i just empty it and would things just start from scratch for settinggroup

            thanks

            Comment


            • #7
              well you can turn off your vB forum via phpmyadmin or the mysql telnet client by running this command on your vb forum database

              Code:
              UPDATE setting SET value='0' WHERE varname='bbactive';
              then try the myisamchk repair
              :: Always Back Up Forum Database + Attachments BEFORE upgrading !
              :: Nginx SPDY SSL - World Flags Demo [video results]
              :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

              Comment


              • #8
                great thanks

                and just so i know before doing this...

                i would then use

                UPDATE setting SET value='1' WHERE varname='bbactive';

                to turn the forums on again. i know pretty basic but i want to make sure

                thanks

                Comment


                • #9
                  Originally posted by mark58
                  great thanks

                  and just so i know before doing this...

                  i would then use

                  UPDATE setting SET value='1' WHERE varname='bbactive';

                  to turn the forums on again. i know pretty basic but i want to make sure

                  thanks
                  yup that would work, but once you repair the forum database you should be able to do that via the admin panel anyway
                  :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                  :: Nginx SPDY SSL - World Flags Demo [video results]
                  :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                  Comment


                  • #10
                    i am on the right database

                    use vbforums; <-- the database i am using

                    then --> UPDATE setting SET value='0' WHERE varname='bbactive';

                    didn't turn off my forums

                    mysql> UPDATE setting SET value='0' WHERE varname='bbactive';
                    Query OK, 0 rows affected (0.00 sec)
                    Rows matched: 1 Changed: 0 Warnings: 0

                    any suggestions? also tried this via phpMyAdmin 2.1.0 without any luck

                    Comment


                    • #11
                      when i did the

                      use forumsvb;

                      i got back

                      mysql> use forumsvb;
                      Reading table information for completion of table and column names
                      You can turn off this feature to get a quicker startup with -A

                      Didn't find any fields in table 'settinggroup'

                      Comment


                      • #12
                        hmmm the only other way is to run an myisamchk by shutting down apache first then shut down mysql and then run myisamchk instructions from http://i4net.tv/marticle/get.php?act...le&articleid=7

                        then start mysql and restart apache again
                        :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                        :: Nginx SPDY SSL - World Flags Demo [video results]
                        :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                        Comment


                        • #13
                          turned off apache
                          turned off mysql

                          did a whereis for mysql

                          put in: /usr/bin/myisamchk /usr/bin/mysql/admin_vb/*.MYI

                          i get this error message

                          /usr/bin/myisamchk /usr/bin/mysql/admin_vb/*.MYI
                          /usr/bin/myisamchk: error: 20 when opening MyISAM-table '/usr/bin/mysql/admin_vb
                          /*.MYI'

                          Comment

                          widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                          Working...
                          X