Announcement

Collapse
No announcement yet.

Many database errors

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Many database errors

    Hey, i am having a flood of emails into my box that say "Subject vBulletin (forum) Database error!", with the error Link-id, connect failed. Any ideas as to why this might happen. It usually happens during peak hours and all at once or all within a couple minutes. The script URL varies. Below is the error.


    Database error in vBulletin: Link-ID == false, connect failed
    mysql error:
    mysql error number:
    Date: Monday 08th of October 2001 10:03:03 PM
    Script: /avatar.php?userid=2174&dateline=995005803
    Referer:



    Thanks!
    Tony Rieker | Founder of PBNation.com - one of the LARGEST vBulletin forums on the net!

  • #2
    What it means is that too many people are trying to connect to the database at the same time and some are being rejected. What you can do to fix it:
    1) Turn off persistant connections. To do this, open config.php and change
    $pconnect=1;
    to
    $pconnect=0;
    if it is not already.
    2) Ask your web host to increase the number of MySQL connections that are allowed at one time.

    Comment


    • #3
      We really need to post this to the Hints and Tips Forum.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        Sorry about that. I just did a search and read a couple threads on this. Persistent connections is turned off in the config.php.

        I read something about mysql's max_connections.. where can i find this variable and what(if i should) should i change it to??

        Thanks!
        Tony Rieker | Founder of PBNation.com - one of the LARGEST vBulletin forums on the net!

        Comment


        • #5
          also, does anyone know what the defualt max_connections is with mysql???
          Tony Rieker | Founder of PBNation.com - one of the LARGEST vBulletin forums on the net!

          Comment


          • #6
            ok, i like to answer my own questions. Im reading the documentation on mysql.com, but one question remains, whats a good number to set the max_connections variable as? and also, it states that the variable will only stay changed for the instance of mysql that i change it for. Any ideas on how to make it a permanent change?


            Thanks!
            Tony Rieker | Founder of PBNation.com - one of the LARGEST vBulletin forums on the net!

            Comment


            • #7
              I believe you do this in the my.cnf file. Check the mySQL Forum for specific examples.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                the default mysql max_connections setting is 100 if the server's mysql configuration has not been altered since mysql was installed.

                Now if you have root access or you have access privileges you will be able to see what your mysql settings are by

                1. checking out what's in /etc/my.cnf file - you'd need root server access to view and modify that file
                2. by telnetting in and switching to root user and typing

                mysqladmin -u root -p variables

                and entering your mysql root password in the prompt after
                :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                :: Nginx SPDY SSL - World Flags Demo [video results]
                :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X