No announcement yet.

Really messed up upgrade!!

  • Filter
  • Time
  • Show
Clear All
new posts

  • Really messed up upgrade!!

    1. Had VB working on v2.0.0 beta 3. fine, but need to change servers, so backed up and off to new server

    2. Did complete install of new version v2.0.3.
    (NOW I realise this might have been wrong due to this quote I've found in the VB community:-
    I read this by moderator Martin (I think)
    You cannot just back up your database and upload the newest version and have it work. There were changes to the database in 2.0.3 that will make it incompatible with tables from earlier versions.
    3. I restored the backup and it appears fine, but obviously it doesnt work, cant actually use it to post anything, getting mysql error 1054 everywhere.

    Plus the CP says its version 2.0.0 beta 3 !!!

    Now I know I've screwed this up, but I'd really like some advice on how o get it up and working again. I know I need to re-install again, but as the server is fresh (no previous VB, untill I botched it) i'd like to know which is the best way..

    Just think, once i get it working this newbie will stay quiet for a long time

    Thanks in advance

  • #2
    all you should have to do is start the upgrades at "upgrade4.php" and run all of them through "upgrade12.php".

    I certainly hope that works for you


    • #3
      Thanks Martin

      I managed to run upgrade 4 thru to 10 then upgrade 11 failed with the same error as "All of a sudden I am getting these errors... " by F5Hosting

      Basically it said:-
      Database error in vBulletin Control Panel: Invalid SQL: ALTER TABLE profilefield ADD editable SMALLINT DEFAULT '1' NOT NULL
      mysql error: Duplicate column name 'editable'
      mysql error number: 1060
      Date: Monday 03rd of September 2001 06:57:54 PM
      Script: /forums/admin/upgrade11.php?step=2
      Referer: http://xx.xx.xx.135/forums/admin/upgrade11.php?

      So I went to upgrade12 (I know it was mad AND foolish, but I have always been a risk taker ) And that worked. I'm still testing the database but it seems to be working. Martin, you're a star, thanks again.

      Last edited by Ben; Tue 9 Oct '01, 4:05am.


      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.