Announcement

Collapse
No announcement yet.

New Server Move - VB 2.3.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • New Server Move - VB 2.3.0

    I have a question.

    My VB was running on an older server and yesterday I moved it to a brand spanking new server in order to upgrade to the latest and greatest. Prior to the move, I shut my board down.

    The old server was running MySQL 3.23.46 and PHP 4.0.6

    The New server is running MySQL 5.0.45 and PHP 5.2.5

    The Mysql connections work and my board is back up and running, showing the splash screen for the board being turned off (the way I left it prior to the move) BUT, it will not recognize my username login. Which means I can't turn the board back on, nor do I want to do the upgrade to 3.0.7 until I get the user accounts working again.

    From 3.0.7 I plan on upgrading to the latest VB 3.8. Can the issue be the newer version of PHP or MySQL not liking the old 2.3.0 version of VB? Do I have to upgrade first to get the user accounts to recognize?

  • #2
    vB 2.x is not compatible with MySQL5 and PHP5. You will need to upgrade to at least 3.7.5.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      I've upgraded to 3.0.7 and that fixed the initial issue with not being able to log on. Now on to the latest upgrade.

      I experienced one little error in upgrade11.php?step=1 . After trying to rerun upgrade11.php I was getting an error with duplicate fields in the user table, so I assume the step took place and just went on the step 2. The rest of the upgradeXX.php files went well to get me to 3.0.7

      All appears to be working at this level, but I plan on moving to the latest this evening. Any issues with going from 3.0.7 to 3.8.1?

      Thanks!

      Comment


      • #4
        You should be able to upgrade directly. You will need to use the 3.8 config.php file though.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X