Announcement

Collapse
No announcement yet.

Avatars

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Avatars

    When I upload an avatar it tells me that it was unable to create file in avatar.php line 35 and something about permissions.

    then it tells me that the upload was successful

    but there is no image.

    Note. There is no Icon at the top of the control panel.
    Last edited by djmac; Mon 24th Sep '01, 10:09pm.
    Stress: The overwhelming desire to choke the s*@t out of someone.

  • #2
    I received the same error. I assume the permissions for the directory you are uploading to need to be changed to let the browser write to it.

    I'm gonna try that and try again.
    My vBulletin/PHP Portals site

    Comment


    • #3
      If you use safe mode you need to chmod the specified directory to 777. The same goes with the avatars directory.
      Ueli

      Comment


      • #4
        I'm on a Win2k server... it still isn't working.

        The permissions to the avatar directory have been changed so the browser can write to it. It seems like VB THINKS the avatar is being uploaded, but it displays no picture when viewed... just an empty box, the broken image. No error appears, either.

        As I understand this from other posts I've read, if you use the upload feature, VB stores the image (or a link to the image) in a table. I assume it also uploads the image to the Avatar directory itself. Or does it put it in a separate directory maybe?

        I'm using VB 2.0.3

        Any other thoughts? Suggestions? Am I correct in my thinking?
        My vBulletin/PHP Portals site

        Comment


        • #5
          Vb stores the avatars in the avatar directory and the path to it in the avatar table.
          Well, I did a little search but couldn't find much. You may look at

          http://www.vbulletin.com/forum/showt...atar+AND+Win2k

          http://www.vbulletin.com/forum/showt...threadid=21707

          I actually also read somewhere that you should change a form tag but can't remember anymore where.
          Ueli

          Comment


          • #6
            OK I think I'm getting this...

            I can't change permissions, my server guy has to do it. Hopefully that'll happen after lunch.

            BUT... I changed the option to safe mode in the Admin CP, as is often recommended here. And the avatar directory does have write permissions. So just to see what'd happen, I put the images/avatars directory in the Admin CP (removing tmp), then I can upload an avatar from my user cp and it works!

            I still cannot do this from the Admin CP. I assume this is because the Admin CP uses the /tmp directory, and that directory cannot be changed anywhere, so I can't use the /images/avatar directory just to test it out. My tmp doesn't have permissions set up yet. Also, perhaps this is also the same for the attachments.

            Question, when unzipping VB initially, it'd be nice to have a /tmp directory in there, even though it'd be empty. And a note to have the permissions on this changed to writable. Seems this simple thing would fix a lot of problems, I've seen many questions about this on the board.
            My vBulletin/PHP Portals site

            Comment


            • #7
              It's not so much that the avatar directory has permissions (although you need that too) but the directory being uploaded to needs write permissions too.
              Create a directory called
              tmp
              within your forum directory and give it write permissions. Then find out from your provider the full path to your forums directory. Add
              /tmp
              on the end of that, and use that for the safe mode upload path (right under the option to turn Safe Mode uploading on in the Admin CP)

              Comment


              • #8
                Ok.. after creating numerous tmp directories in various places, it works. I think the tmp directory it's looking for is in .../vbulletin/admin/tmp. Also the .../images/avatars directory needs the same permissions. I also have a c:/tmp dir, but that one didn't seem to have any affect.

                So, my fix was:

                Make the ../images/avatars directory writable.
                Make the ../Vbulletin/admin/tmp directory writable.

                And throw in a couple more just for fun.

                Thanks for the help, I'm glad this is working, it's a great feature! (now for the last problem.. the email...)

                My vBulletin/PHP Portals site

                Comment

                Loading...
                Working...
                X