Announcement

Collapse
No announcement yet.

Can't Upload/Post Images/attachments

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't Upload/Post Images/attachments

    Hello,
    I've a problem with uploading pictures etc.. I did read through some posts and found a "fix" which prompts to add.

    $allowimgsizefailure;

    To the global which I have done. This allows me to post and no longer gives me the "file is not a valid GIF or JPG ...." however, the file attachemt link shows up but cannot be displayed when you click on it.. just our friend the red "X" shows up. I've tried safe mode but my host does not allow this.

    http://www.fraggersforum.com/forum

    http://www.fraggersforum.com/phpinfo.php

    ideas?
    Thanks
    Kodo
    Kodo
    New Member
    Last edited by Kodo; Thu 13 Sep '01, 5:16pm.

  • #2
    open_basedir
    /usr/local/plesk/apache/vhosts/fraggersforum.com/httpdocs
    open_basedir's more limiting than safe_mode -- it completely kills uploading, because it won't let you read files in /tmp (which is where PHP puts the uploaded file temporarily).

    The only option you'd really have is to see if your host can turn off open_basedir, and possibly even safe_mode (it's quite limiting too). OR, to change the upload_tmp_dir for you such that it's inside /usr/local/plesk/apache/vhosts/fraggersforum.com/httpdocs, and therefore within the open_basedir.

    Comment

    widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
    Working...
    X