Announcement

Collapse
No announcement yet.

Trying to upgrade Vb2 (I know I know)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Trying to upgrade Vb2 (I know I know)

    I am trying to move my vb2 install to a new server so that I can upgrade to the latest Vb3

    Database error in vBulletin 2.3.9:

    Invalid SQL: SELECT user.*, style.templatesetid
    FROM subscribethread,user,usergroup
    LEFT JOIN style ON (IF(user.styleid=0, 1, user.styleid)=style.styleid)
    WHERE subscribethread.threadid='173372'
    AND subscribethread.userid=user.userid
    AND usergroup.usergroupid=user.usergroupid
    AND user.userid<>'20'
    AND user.usergroupid<>'3'
    AND usergroup.canview = 1
    AND user.lastactivity>'1217945799'
    mysql error: Unknown column 'user.styleid' in 'on clause'

    mysql error number: 1054
    I have tried setting the sql mode to 4.0 without luck.

    Am I out of options other than upgrading?
    http://forums.cpfc.org/

  • #2
    That error means that you server is running a newer version of MySQL that is not compatible with vB 2.3.9, which was written many years before your version of MySQL was available. You would have to either downgrade MySQL and possibly PHP, or upgrade vB.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Originally posted by Steve Machol View Post
      That error means that you server is running a newer version of MySQL that is not compatible with vB 2.3.9, which was written many years before your version of MySQL was available. You would have to either downgrade MySQL and possibly PHP, or upgrade vB.
      With respect isn't this just repeating what my post says?
      http://forums.cpfc.org/

      Comment


      • #4
        My apologies. I assumed that I was answering your question directly:

        Am I out of options other than upgrading?
        It won't happen again.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          will vb 3.7 run on mysql 4.0.27 and php 4.3?
          http://forums.cpfc.org/

          Comment


          • #6
            Originally posted by Dave# View Post
            will vb 3.7 run on mysql 4.0.27 and php 4.3?
            The minimum system requirements of vBulletin 3.7 are PHP 4.3.3 and MySQL 4.0.16

            http://www.vbulletin.com/features.php
            http://www.vbulletin.com/forum/showthread.php?t=268833
            Minatica.be - Belgian/Dutch computer and technology site
            DownloadsII - Add a downloads database to your vB 4

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X