Announcement

Collapse
No announcement yet.

Refreshing and Gzip

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • TommyBALL
    replied
    And now my Mozilla user start complaining about trouble when they use the history-back button...

    Seem this "fix" is making more problems than they solve. I'm sad to say that I'm throwing it out again...

    Regards
    - Tommy

    Leave a comment:


  • Rostor
    replied
    LOL

    Leave a comment:


  • TommyBALL
    replied
    Ah. Thanks, but I think you misread my previous post...
    HTTP 1.1 browsing is NOT the problem with your "fix".
    HTTP 1.0 browsing on the other hand gives me blank pages...

    I use IE 6 with Win XP. Turning OFF HTTP 1.1 gives me blank pages...

    Thanks for trying, anyways

    Regards
    - Tommy

    Leave a comment:


  • Rostor
    replied
    Hi Tommy,
    here is the last modify for global.php to make Gzip work with HTTP 1.1 browser:
    PHP Code:
    @header("Content-type: gzip");
    @
    header("Content-type: text/html"); 
    By adding Content gzip before text/html you solve I.E. cache problems.
    By leaving text/html after gzip you solve http 1.1 browser like mozilla.
    Try it and let me know

    Leave a comment:


  • TommyBALL
    replied
    I'm sorry to dissapoint a few ppl now.

    By doing the "@header" change, you will make the pages not working with non-HTTP 1.1 browsers.

    I tried this, and ended up with blank pages when I turned off HTTP 1.1 on my browser.

    Regards
    - Tommy

    Leave a comment:


  • Rostor
    replied
    No Problem BieDdoS,

    after finding the solution it's a pleasure to help you to fix your board

    I like facts not words ... such it's not my problem

    Leave a comment:


  • BieDdoS
    replied
    I want to thank Rostor
    he helps me to change some code in global.php and i resolve the problem with gzip...

    He was very kind with me!!!! Again Thank you Rostor!!!!!!!!

    Leave a comment:


  • BieDdoS
    replied
    Originally posted by tubedogg
    ...which would kind of prove the point that it is indeed a problem with IE and not vB.
    Yes but is it possible that we/you can resolve it???

    Leave a comment:


  • tubedogg
    replied
    ...which would kind of prove the point that it is indeed a problem with IE and not vB.

    Leave a comment:


  • BieDdoS
    replied
    The problem remain with Mac and Ie but not with Netscape...

    Leave a comment:


  • BieDdoS
    replied
    i have the same problems.. now i try with that new codes

    Leave a comment:


  • Rostor
    replied
    Finaly I found a solution.

    In the Start Headers options of global.php I change:

    @header("Content-type: text/html");

    directly in

    @header("Content-type: gzip");

    now seems that the problems are solved.

    What do you think ?

    Leave a comment:


  • TommyBALL
    replied
    MiF: Could you PM me your boards URL?

    Regards
    - Tommy

    Leave a comment:


  • Rostor
    replied
    Thx MiF
    I'v tryed all the possible combination of:
    Add Standard headers & Add No-cache headers
    but nothing change.

    Leave a comment:


  • MiF
    replied
    I'v notice from users, that people connecting with fast line such dsl haven't this problem regardless I.E. version they use
    I use DSL and IE 6 and I saw the problem on your board. No problem on mine though.

    Don't know if this would make a difference but I do not have "send headers" option set. Try disabling it if you have it set.

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X