Announcement

Collapse
No announcement yet.

Getting an error when trying to view threads

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Getting an error when trying to view threads

    I've just started getting errors while trying to view threads on my board. It happens with all threads (at least all those that I tried, in several forums).

    The webhost's server was down for a while tonight, and maybe the mysql server is also having problems. But if that were the case, then wouldn't the board be completely inaccessible? As it is now, I can see the board, see the forums, I just can't read threads.

    I have not installed any hacks or otherwise modified the board in between the last time it worked and now.

    This is the error message I get:
    Database error in vBulletin: Invalid SQL:
    SELECT
    session.userid AS sessionuserid,
    post.*,post.username AS postusername,post.ipaddress AS ip,user.*,userfield.*,icon.title as icontitle,icon.iconpath,
    attachment.attachmentid,attachment.filename,attachment.visible AS attachmentvisible,attachment.counter
    ,avatar.avatarpath,NOT ISNULL(customavatar.avatardata) AS hascustomavatar,customavatar.dateline AS avatardateline
    FROM post
    LEFT JOIN icon ON icon.iconid=post.iconid
    LEFT JOIN user ON user.userid=post.userid
    LEFT JOIN userfield ON userfield.userid=user.userid
    LEFT JOIN avatar ON avatar.avatarid=user.avatarid
    LEFT JOIN customavatar ON customavatar.userid=user.userid
    LEFT JOIN attachment ON attachment.attachmentid=post.attachmentid
    LEFT JOIN session ON (session.userid = user.userid
    AND session.userid > 0

    AND session.lastactivity>1000102074)
    WHERE post.postid IN (0,233694,233725,233731,234080,234190,234218,234221,234236,234513,234681)
    ORDER BY dateline

    mysql error: Got error 28 from table handler
    mysql error number: 1030
    Date: Monday 10th of September 2001 02:22:54 AM
    Script: /forums/showthread.php?s=&threadid=24829
    Referer: http://www.jjr512.com/forums/forumdi...p?s=&forumid=7
    -Justin "JJR512" Rebbert
    JJR512.com: Chat about anything!

  • #2
    c:\mysql\bin>perror 28
    Error code 28: No space left on device
    You'll need to contact your host and ensure there is enough space left on the MySQL partition (usually /var).

    To verify this, log-in via telnet and type
    df
    at the command prompt. If any are especially high percentages, particularly /var, you need to ask your host to clear some space somehow.

    http://www.vbulletin.com/forum/showt...ghlight=%2Fvar

    Comment


    • #3
      Nevermind... the problem is also occurring on a test board that I have which I haven't modified in a while, so I know it's not the vB software or any problem in it, but must be a problem with the MySql server. So I'll get on them about it.
      -Justin "JJR512" Rebbert
      JJR512.com: Chat about anything!

      Comment


      • #4
        Code:
        Filesystem           1k-blocks      Used Available Use% Mounted on
        /dev/hda8               256667    256653         0 100% /
        /dev/hda1                31079      3275     26200  11% /boot
        /dev/hda9             34867008   8458392  24637452  26% /home
        /dev/hda5              2522048   1261152   1132780  53% /usr
        /dev/hda6               521748    427216     68028  86% /var
        Is the 86% for var something to worry about?
        -Justin "JJR512" Rebbert
        JJR512.com: Chat about anything!

        Comment


        • #5
          Yes, especially with that small of a partition. You could easily eat up 60KB with temporary files while MySQL works.

          Comment


          • #6
            Sorry, I wish I had seen this thread earlier: http://www.vbulletin.com/forum/showt...threadid=25820

            Doh!
            -Justin "JJR512" Rebbert
            JJR512.com: Chat about anything!

            Comment

            Loading...
            Working...
            X