Announcement

Collapse
No announcement yet.

doing a search problems.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • doing a search problems.

    Hello-

    I have a slight problem.. I'm trying to add a small search field on the front page of my site.. however, when i run the search i get:

    "Sorry - no matches. Please try some different terms. "

    on the other hand i go to the board offical search and it returns the messages that i was trying to search for in the search box i put on the front page of my site. I've been trying to get this to work for sometime but I'm not sure what I'm doing wrong. I've looked at the source in the HTML and for the PHP code and I'm just lost.

    If you would like to see what I am talking about go to:

    http://64.132.13.124:82

    you'll see the text field i'm talking about on the right.. enter "test" and search for it (w/o quotes of course). You won't get any results. Then if you go to the search for the offical board and search for "test" it returns the correct information.

    thanks,
    jay

  • #2
    Could you please enter your license info into your user profile? See my sig foir details. Thanks!
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Okay just entered the information and I also updated where the software is located right now in the members section. It's on my development server as of now, and when I get the site up and running fully functional I plan to move it over to the production machine. However, I'd really like to figure out this search problem I'm having.

      Thanks,
      Jay

      Comment


      • #4
        Ok, I just took a look at this and confirmed that your search on the non-vB page isn't working. However this really isn't a vB trouble-shooting issue since vB works correctly. Without knowing what you've coded into this search, it would be difficult to make any suggestions. You might want to post a question along with your code on the PHP forum.

        Next, and most importantly, you need to update your vB to 2.0.3 as soon as possible. The version you're running has a known secutiry hole. Look here for more details:

        http://www.vbulletin.com/forum/showt...threadid=24116
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          okay I'll post my question on the php forum, however i haven't changed any of the php code on the no-VB page.. it's just a <form> with actions etc that I thought it needed to have to run correctly...

          <form action="forum/search.php" method="post" name="submitForm">
          <input type="hidden" name="action" value="simplesearch">
          <input type="text" name="query" value="" size="6">
          <input type="image" src="images/button_search.gif" name="Search" value="Perform Search" accesskey="s" border="0">Search our forum!
          </form>

          but that is the html code i'm using to call the search.

          Thanks,
          Jay

          Comment


          • #6
            Try the following code. And replace your variables accordingly.

            Code:
            <form action="search.php" method="post">
            <input type="hidden" name="s" value="$session[sessionhash]">
            <input type="text" class="bginput" name="query" size="6">
            <br>
            <input type="submit" class="bginput" name="Submit" value="Perform Search" accesskey="s">
            </form>
            Board of the Month: November
            Websites: Pixeljunction , vBulletin.org
            Button Sets: XP and Aqua Button sets! FREE!
            vB Customization: My sig is now vbulletin compliant. Contact me to make yours compliant too!

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X