Announcement

Collapse
No announcement yet.

Set up backup

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Set up backup

    How do I set up the backup
    In the control pannel the file
    "./forumbackup-08-14-2001.sql" is the default. It further says:
    "PHP must have access to write in this directory (usually chmod 0777)"

    I understand chmod but where is this file, what directory is it to be in so I can chmod it.

    PS: I am a licensed user
    Thanks

  • #2
    That's your home directory. It's generally not a good idea to chmod that to 0777. What I did was create a directory called 'backups' and chmod'd that to 0777. Then change the backup path and filename to:

    backups/forumbackup-08-14-2001.sql
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Well, it sounded simple. I created a directory in my forums directory called backup. It has no files in it. I changed the directory permission to 777 and it still won't work.

      The error as follows:
      Warning: fopen("forums/backup/backup-08-15-2001.sql","w") - No such file or directory in
      /home/domain/data/forums/admin/backup.php on line 245

      I even tried to create the file name and make it 777 too but no good.
      Now what!

      Comment


      • #4
        Steve, when I put "./forumbackup-08-14-2001.sql" in the path field, the file is created in the admin folder (because backup.php is in the admin folder).
        Chen Avinadav
        Better to remain silent and be thought a fool than to speak out and remove all doubt.

        גם אני מאוכזב מסיקור תחרות לתור מוטור של NRG הרשת ע"י מעריב

        Comment


        • #5
          You could specify the path by creating your chmod'd 0777 directory, and typing PWD (gives you the current path to the backups folder you are in). Its probably a good idea to put the backups folder below the web directory - you don't want anyone getting hold of your .sql file now do you?

          Then you can edit the backup.php and change the default path to something like:

          /home/www.domain.com/backups

          Works for me
          HP DL-380 G6, 2x E5520, 28GB RAM, 4x300GB SAS, VMWare ESXi
          -
          Unreal Tournament : Assault forums - irc://irc.utassault.net:6667 -

          Comment


          • #6
            Thanks smachol . Martz. FireFly

            I was having probems with this for sometime along with some other people. Your solution worked.

            Joey
            Real Web Host

            Comment


            • #7
              You guys lost me a little. It sounds like I would need to chmod my admin directory to 777 but that is a bad idea. I really need to place this file in it's own directory that is 777. I do not know how the PWD works. I found the PWD in the FTP command list.
              I understand the backup.php would need to be edited to change the path. What should I change. Can you give me an example.
              Thanks

              Comment


              • #8
                No - definitely do not chmod your admin directory to 0777!

                Just create a new directory called 'backups This doesn't even have to be in your forums directories - I have mine just off my home directory(i.e., /home/smachol/backups). Then as was mentioned you can use the command 'pwd' to find out the correct and full path to that directory which you can then use when making your backup.
                Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                Change CKEditor Colors to Match Style (for 4.1.4 and above)

                Steve Machol Photography


                Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                Comment


                • #9
                  I got it to work. Thanks for everybody's help.

                  Comment


                  • #10
                    x smachol

                    No - definitely do not chmod your admin directory to 0777!
                    Excuse me. Where can I found the right permission settings for each directory/file of VB 2.2.1 ?
                    I always made upgrades (the first version was installed by one friend of mine who doesn't remember ... ) and now I have almost all dirs moded to 777 !?!?!


                    Thank you very much
                    Bye

                    Comment


                    • #11
                      There is no folder permission settings for folders in vBulletin, but it's still very unrecommended to CHMOD any of your folders to 0777.
                      (security reasons)
                      Chen Avinadav
                      Better to remain silent and be thought a fool than to speak out and remove all doubt.

                      גם אני מאוכזב מסיקור תחרות לתור מוטור של NRG הרשת ע"י מעריב

                      Comment


                      • #12
                        I guessed...
                        but ... Ehhhmmm, I come from Ikonboard, where each directory or file have their own permission settings to apply.


                        Nothing here ?
                        If I had each dir moded to 0777, should I set to 0755 o 0644 or whatever ?

                        Thanks a lot.
                        Bye

                        Comment


                        • #13
                          I would go 0644 which is Read,Write; Read; Read for Owner Group and World respectively.

                          Comment


                          • #14
                            Thanks a lot.
                            So, CHMOD 0644 for every file and dir ?

                            What about the images or uploads or tmp ?
                            I guess - only for these - 0755 or 0777, isn't it ?
                            Thanks again.
                            Bye

                            Comment


                            • #15
                              If you require an uploads or temporary directory, it must be CHMODed 777. Also if you use the Admin CP to upload icons or avatars, those two directories must also be CHMODed 777.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X