Announcement

Collapse
No announcement yet.

Associate Style/Template Set with URL

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Associate Style/Template Set with URL

    Hi,

    Is there any way that I can make vBulletin display with a special template if I access it using a special URL, for example:

    http://www.domain.com/forums/index.php?style=22 ?

  • #2
    Close.

    yourforums.com/forums/index.php?styleid=22

    Comment


    • #3
      Okay--now if I decide to hack off certain fields on forums home and change colors and use different buttons, will this style stay with the user so long as he doesn't re-enter using the normal URL?

      In other words, if I create a Pocket PC website and make everyone from this website access vBulletin through the special URL, will I be able to create a "stripped" version of vBulletin for him, by having fewer elements show up and use smaller buttons?

      Comment


      • #4
        If they specify a style, it should stay with them, correct. The only time it wouldn't is if you specify a style for a forum (other than the default) and tell it to "override" other styles.

        Comment


        • #5
          Weird!

          Now the way it's setup is that if I enter:

          http://www.pocketnow.com/forums/index.php?styleid=1, I get the default desktop style. If I enter:

          http://www.pocketnow.com/forums/index.php?styleid=2, I get the mobile style.

          However, if I just enter:

          http://www.pocketnow.com/forums/, I get the mobile style, which is NOT "default."

          All of the individual forums are set to use "default," but the home view and all forums are actually displayed with the mobile style.

          How do I *properly* force a default style set unless the styleid "option" is used? In other words, normal desktop users will access the desktop version using:

          http://www.pocketnow.com/forums/ and the mobile users will access using:

          http://www.pocketnow.com/forums/index.php?styleid=2.

          NOTE: I have disabled user selection of styleid 2 (mobile) because it would display this for the desktop users under my current configuration.

          Thanks for the help!

          Comment


          • #6
            You went to style 1, then 2, then none? Then, by what you did, you should be seeing #2 -- without a cookie/session method of handling the style, every link would have to have the styleid written into it.

            Go to 2, then 1, then none, and the last page should appear as #1.

            Comment


            • #7
              Okay--that worked, but what about the users who want to just enter http://www.pocketnow.com/forums/ ? If I clear my cookies then visit this page, I still see the mobile (non-default) style set.

              We could work around this, but I'd prefer a direct solution.

              Comment


              • #8
                Never mind--it all works now. Thanks for the help!

                Comment


                • #9
                  Originally posted by jminiman
                  Never mind--it all works now. Thanks for the help!
                  Do you mind sharing this with the rest of us? Thanks!
                  www.nrg.be - www.ultrashock.com

                  Comment

                  Loading...
                  Working...
                  X