Announcement

Collapse
No announcement yet.

Here's one that's repeatable on my board.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Here's one that's repeatable on my board.

    Click on a users profile icon when reading a thread they have posted in. You have NOT logged in yet as admin. Click on Admin options: User Options link. Up pops the admin screen to login. Login and BOOM...the main frame shows an error:

    HTTP/1.0

    Error 404

    Object Not Found

    If you are already logged into admin, up pops the users details of course.

    I can repeat this one until the cows come home. Every time.

  • #2
    OK so this isn't just me...I was just saying this and I couldn't reproduce it elsewhere. Now that you've said that I'm going to try it the exact way you did.

    Comment


    • #3
      Hi Jucs,
      We are trying everything to try reproducing this. I can on my board, but no one else can. Is there anything you can think of that might make your server unique?

      Comment


      • #4
        Nope. Nothing that I am aware of. I believe my server info dump was posted in one of my old posts.

        Comment


        • #5
          A couple of thoughts:

          Firstly, which browser are you using?

          Secondly, what is the URL that is giving the 404?

          Thanks,
          John
          John Percival

          Artificial intelligence usually beats real stupidity ;)

          Comment


          • #6
            Actually, this should now be fixed in 2.0.2 I believe...

            Comment


            • #7
              It's not fixed. I got it again with V2.02

              I am using IE 5.5. I have a BIG problem (see my other post) besides this one. Uggggh.

              Here's the URL when the error is generated:

              http://mysite.com/forums/admin/index...8da01ab5b7aec7
              Last edited by jucs; Tue 31 Jul '01, 5:05pm.

              Comment


              • #8
                This is STILL a repeatable problem in 2.03. Every single time I can repeat this.

                Comment


                • #9
                  The problem is here:

                  Code:
                  user.php%26action
                  I am unsure how that is getting there though. Just check that you have indeed uploaded the new moderator.php

                  mysite.com does not seem to have a directory called forums, so could you please post the actual url of the place that provides the 404 - the page of the 404 error, not the page that redirects you to a 404 error please.

                  Thanks,
                  John
                  John Percival

                  Artificial intelligence usually beats real stupidity ;)

                  Comment


                  • #10
                    Funny that you mention it... I used to have that problem also, but it seems to have disappeared when I upgraded to 2.0.2.

                    Comment


                    • #11
                      Correct info

                      There's no question I have the right moderator.php file

                      Here's the correct URL:

                      http://hardgainer.com/forums/admin/i...it%26userid=16

                      Comment


                      • #12
                        A screen shot

                        Follow the sequence I posted above and this is what I see:

                        Comment


                        • #13
                          Okay, I think I've fixed this, but as it has always worked for me, I can't be sure...

                          Try this. Open moderator.php in your forums directory, and find these lines:
                          PHP Code:
                            if ($permissions[cancontrolpanel]) {
                              
                          header("Location: admin/index.php?s=$session[sessionhash]&loc=user.php?s=$session[sessionhash]%26action=edit%26userid=$userid");
                            } elseif (
                          $permissions[ismoderator] or $ismod=$DB_site->query_first("SELECT * FROM moderator WHERE userid=$bbuserinfo[userid] AND canviewprofile=1")) {
                              
                          header("Location: mod/index.php?s=$session[sessionhash]&loc=user.php?s=$session[sessionhash]%26action=view%26userid=$userid"); 
                          then replace them with this:
                          PHP Code:
                            if ($permissions[cancontrolpanel]) {
                              
                          header("Location: admin/index.php?s=$session[sessionhash]&loc=".urlencode("user.php?s=$session[sessionhash]&action=edit&userid=$userid"));
                            } elseif (
                          $permissions[ismoderator] or $ismod=$DB_site->query_first("SELECT * FROM moderator WHERE userid=$bbuserinfo[userid] AND canviewprofile=1")) {
                              
                          header("Location: mod/index.php?s=$session[sessionhash]&loc=".urlencode("user.php?s=$session[sessionhash]&action=viewuser&userid=$userid")); 
                          Please let us know if this solves your problem!

                          Comment


                          • #14
                            And the verdict is...drum roll please...

                            BING, BANG, BOOM!

                            Fixed!

                            Thank you. It was annoying.

                            Comment


                            • #15
                              YAY! The fix will be in vBulletin 2.0.4

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X