Announcement

Collapse
No announcement yet.

Enable search, server crash.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Enable search, server crash.

    Every time I enable the search, the server start to crash every while, at least once a day.

    -----
    vb 2.0.1
    cpu: 1G
    ram: 0.5G
    mysql: 3.23.36

    average concurrent users online: 100 (load is below 1)
    max users: 150
    posts: 200,000
    Last edited by Essam; Sat 28 Jul '01, 4:16pm.

  • #2
    Ensure your searchindex table has an index on (wordid, postid). I believe it's in that order.

    Comment


    • #3
      that what phpmyadmin shows:

      Keyname Unique Field Action
      PRIMARY Yes wordid Drop
      PRIMARY Yes postid Drop


      So I think it does have indexes.

      Comment


      • #4
        Mine says
        Keyname Unique Field
        wordid Yes wordid
        wordid Yes postid

        Comment


        • #5
          Same thing.

          If you have a slow query log, you might want to take a look at the end of it -- hopefully it'll show a slow query that most likely eventually took down the server.

          Comment


          • #6
            Originally posted by Ed Sullivan
            Same thing.

            If you have a slow query log, you might want to take a look at the end of it -- hopefully it'll show a slow query that most likely eventually took down the server.
            The slow query percentage is usually very small, where can I check the log?

            Comment


            • #7
              Actually, you might not have it -- I think it depends on a compile flag.

              When you have searching enabled, is it any search that crashes the server? Or have you not had a problem with searches?

              Comment


              • #8
                Ok, not a compile flag -- a startup flag: http://www.mysql.com/doc/S/l/Slow_query_log.html

                If you can start up MySQL with that option, it might be more beneficial in finding the problem.

                Comment


                • #9
                  It's a my.cnf setting

                  log-slow-queries

                  Then you would find the log in your mysql directory.

                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X