Announcement

Collapse
No announcement yet.

instalation step 3 - no permission db_mysql.php

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • reveltaion456
    replied
    Originally posted by msobel
    I gave up and paid my web host to install it.
    They did not tell me what had to be done but it works. I will ask them and let you know what it took.
    Thanks

    Leave a comment:


  • msobel
    replied
    I gave up and paid my web host to install it.
    They did not tell me what had to be done but it works. I will ask them and let you know what it took.

    Leave a comment:


  • reveltaion456
    replied
    Originally posted by Ed Sullivan
    Yes, that's a permissions issue on your host's side -- nothing we can do about it here.

    Best we can do is to tell them to make sure they flushed the grants correctly after making any changes ( FLUSH PRIVILEGES; ) -- if you give them that specific error it should help them troubleshoot.
    I am getting the same problem from my host (Ventures Online). What steps can I take to get this fixed -- I don't quite understand what you were saying.

    Leave a comment:


  • Mike Sullivan
    replied
    If you want to access the MySQL server, you need a client program. The 2 most commonly used ones are "mysql", used by a telnet interface, and phpMyAdmin, which is used via PHP.

    mysql:

    mysql -uUSERNAME -p DATABASENAME

    Cchange USERNAME and DATABASENAME to your appropriate settings. You should then be prompted to enter your password. From there, you can run queries on your database.

    I'm not going to go into phpMyAdmin as there's a tutorial in the troubleshooting forum that should cover most things. phpMyAdmin's probably a bit more intuitive as it provides more options for someone who doesn't know SQL (I mean the language).

    Either way you don't access the server directly -- you use a client which talks to the server. When your host corrects this permission problem, you are essentially getting access to the server, with vB acting as the client.

    Leave a comment:


  • msobel
    replied
    other questions

    Could you answer my other questions about access to the special files etc.
    Thanks

    Leave a comment:


  • Mike Sullivan
    replied
    Yes, that's a permissions issue on your host's side -- nothing we can do about it here.

    Best we can do is to tell them to make sure they flushed the grants correctly after making any changes ( FLUSH PRIVILEGES; ) -- if you give them that specific error it should help them troubleshoot.

    Leave a comment:


  • msobel
    replied
    full error message

    Here is the full message:
    Warning: Access denied for user: '[email protected]' (Using password: YES) in
    /home/basslakeca.com/data/forums/admin/db_mysql.php on line 38

    Warning: Supplied argument is not a valid MySQL-Link resource in
    /home/basslakeca.com/data/forums/admin/db_mysql.php on line 47

    The database has failed to connect because you do not have permission to connect to the server. Please go back to the last step and
    ensure that you have entered all your login details correctly.

    Leave a comment:


  • Mike Sullivan
    replied
    We need the full error message you're getting -- then I can tell you specifically the problem, although I'm pretty sure it is a permissions issue with your host.

    Leave a comment:


  • msobel
    started a topic instalation step 3 - no permission db_mysql.php

    instalation step 3 - no permission db_mysql.php

    Upon installing I get this error (inpart)
    "....forums/admin/db_mysql.php on line 38"
    it goes on to say I don't have permission to access this file.

    My web host says there server is ok. Do I have to do a chmod to a file to get started.

    Another question is, is "localhost" a correct setting or am I suposed to insert my domain name.

    How do I get access to the servers special files that run the data base. All I have is FTP access.
widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X