Announcement

Collapse
No announcement yet.

Installed gzip - weired output

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Installed gzip - weired output

    I just compiled and installed gzip, but when I turn on gzip in the CP the following is the result, when I open the index Page.
    Code:
    ‹xí\ÙrÇ’}–"ôex¬ÅÆÎE$àš hÓ"E IFž¸¡¨F€{{!EúΟNļøæÉs2«w4)p±e
    E˜‹ì¥²²²²²Nfev﫝Ãí“w¯‡âÇ“ƒ}ñúÍÖþÞ¶¨5Z­·KÛ­ÖÎÉŽ~°Ülwĉ/ÝÀ -Ï•6ž kƒG{Óбù·
    ’&~?è}Õh×#9š*1Å]å¢ÑàgŽ ¥˜†á¬¡~‰¬³~íµ/'Ž¬‰‘ç†Ê û5×kpK¢ý 7÷þ'?Î,_9zÎ
    ”¶‰¿Æ6úõ=;× Ø F¹æBsèJGõk§êâÜóÍ|ïgFd
    Û*´ÜúØó#§nAÝ´‚Qbýƒ
    ²o‡ER¦ F¾5#QçXÛ;ÜÝV e¹bÇ N5™€i C…¾¥ å Ç ÅÙVÜsS¼q„)±KˆË/ÆîÖ
    ÅDaŠp‡fd£Õ:??oZ^x6nšªuf´·uÔÔ¿ÊÏhRååÔ¿‚J:îæÈsˆÎÿ } ÂËȝˆ3Ï»þÅ¥eŠ§cþýýÄùØ´
    ­g± B+´Õ€GÛO÷\o<¶.-IbÊw5å!?ëµô«™øòºup|2UŽÚöœ™ -ÃV9Q¾ƒ’@ê½ ¼°•/f˜¿P}
     [£€lB·÷÷·6...
    Problem exists in IE5.5 and NS 4.7

    my phpinfo:http://62.67.214.27/top/info.php

    If I turn off gzip - everything is fine,
    Level 0: Only a few weired chars
    Level 1: see above.

    What is wrong?

    THX!

    scotty
    Last edited by scotty; Tue 10 Jul '01, 1:20pm.
    There is no spoon!!!

  • #2
    oops - or maybe this is a "server configuration" issue?
    There is no spoon!!!

    Comment


    • #3
      I had this also, but as suddenly as it appeared, it disappeared and haven't seen the affect since.

      The developers couldn't help when I emailed them, but I'm suspecting it's a browser issue rather than a fault with mod_gzip.

      Comment


      • #4
        THX bob

        Hm, but I just talked with my Test Users and they ALL have the Problem...

        weired
        There is no spoon!!!

        Comment


        • #5
          Hmm... wired indeed, do you receive the mailing list posts?, if so, post your problem there and perhaps the developers will look the issue further.

          Sorry I cant help any.

          Comment


          • #6
            Can you post the URL to your board?

            Comment


            • #7
              Originally posted by Ed Sullivan
              Can you post the URL to your board?
              I sent you a PM - THX
              There is no spoon!!!

              Comment


              • #8
                Ugh -- came up correctly for me. Kinda makes it hard to troubleshoot then.

                Comment


                • #9
                  Originally posted by Ed Sullivan
                  Ugh -- came up correctly for me. Kinda makes it hard to troubleshoot then.
                  shure - at 1:00 AM I turned gzip off.

                  I'll try to recompile apache with diff. parameters, and when it still got probs, I will post again.

                  scott
                  There is no spoon!!!

                  Comment


                  • #10
                    ok - recompiled php & apache; params see here: http://62.67.214.27/top/info.php

                    at the moment I have gzip on, but compression level=0

                    and on top of each page is "‹xÚJMµ²"
                    and on the bottom is "Šð -JM"

                    If I turn over to level=1, by going to the index of the forum the browser would like to download "index.gz"

                    here the relevant lines from http.conf:
                    Code:
                    <IfModule mod_gzip.c> 
                    mod_gzip_on Yes 
                    mod_gzip_minimum_file_size 300 
                    mod_gzip_maximum_file_size 0 
                    mod_gzip_maximum_inmem_size 100000 
                    mod_gzip_item_include file .htm$ 
                    mod_gzip_item_include file .html$ 
                    mod_gzip_item_include file .shtml$ 
                    mod_gzip_item_include file .shtm$ 
                    mod_gzip_item_include file .jsp$ 
                    mod_gzip_item_include file .php$ 
                    mod_gzip_item_include file .pl$ 
                    mod_gzip_item_include file .cgi$ 
                    mod_gzip_item_include mime text/.* 
                    mod_gzip_item_include mime ^application/x-httpd-php 
                    mod_gzip_item_include mime httpd/unix-directory 
                    mod_gzip_item_include handler ^perl-script$ 
                    mod_gzip_item_include handler ^server-status$ 
                    mod_gzip_item_include handler ^server-info$ 
                    mod_gzip_item_exclude file .css$ 
                    mod_gzip_item_exclude file .js$ 
                    mod_gzip_item_exclude mime ^image/.* 
                    mod_gzip_dechunk yes 
                    mod_gzip_temp_dir /tmp 
                    mod_gzip_keep_workfiles No 
                    mod_gzip_can_negotiate yes 
                    </IfModule> 
                    
                    AddEncoding x-compress Z
                    AddEncoding x-gzip gz tgz
                    
                    AddType application/x-httpd-php .php
                    AddType application/x-httpd-php-source .phps
                    
                    AddType application/x-tar .tgz
                    AddType application/x-gzip .gz

                    What is wrong?

                    scotty
                    Last edited by scotty; Wed 11 Jul '01, 9:29am.
                    There is no spoon!!!

                    Comment


                    • #11
                      Could the Problem be, that mod_gzip and zlib are installed?

                      But the Prob with the "index.gz" was there before installing mod_gzip.

                      ???

                      scott
                      There is no spoon!!!

                      Comment


                      • #12
                        YOu will have problems if you use vBulletin's gzip compression along with mod-gzip or ob_gzhandler automatically.

                        You should choose one of the three methods for compression and use it.
                        Translations provided by Google.

                        Wayne Luke
                        The Rabid Badger - a vBulletin Cloud demonstration site.
                        vBulletin 5 API

                        Comment


                        • #13
                          Originally posted by wluke
                          YOu will have problems if you use vBulletin's gzip compression along with mod-gzip or ob_gzhandler automatically.
                          ob_gzhandler is not active

                          The Problem extist although before I installed mod_gzip.

                          the zlib in PHP is needed for the vBullezin gzip Kompression, right?
                          You should choose one of the three methods for compression and use it.
                          And which one is the best?

                          thx

                          scott
                          There is no spoon!!!

                          Comment


                          • #14
                            the zlib in PHP is needed for the vBullezin gzip Kompression, right? And which one is the best?
                            If your using mod_gzip then no other compression module should be nessasry. I use gzip to compress all pages including php and it works great.

                            Comment

                            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                            Working...
                            X