Announcement

Collapse
No announcement yet.

[RELEASE] PluhNews 1.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ok this hack is GREAT, when i am logged on my board. But when i am logged out. i get this error

    Warning: Cannot add header information - headers already sent by (output started at /path/to/index.php:10) in /path/to/admin/functions.php on line 1457

    Note: it shows the direct path i didnt want to show it on here to save somewhat privacy. But anyone have any ideas on how to fix it? I am using 2.0.3.

    You can view it at S-Files Online

    Thanks .
    Last edited by Goldfinger; Thu 13th Sep '01, 4:46am.

    Comment


    • I just ran into this on another hack. I found that it was because the database name and password was wrong, check your Pluhconfig file for proper settings
      Real Web Host

      Comment


      • all the variables are right in the PluhConfig.

        Comment


        • Still have the same problem Web. Even after you fixed it... i cleared my cookies. and it didnt work. but if im cookied it'll work..

          Comment


          • Brilliant Script ... saved me alot of hairpulling and pain ...

            I am getting the same header problem ...

            My index is basicly a series of includes

            PHP Code:
            <? include ("location/includes/header.php")?>
            various html for table layouts
            <? include ("forums/PluhNews.php")?>
            various finishing html
            <? include ("location/includes/footer.php")?>

            Comment


            • I can already guess that the inclusion of the global.php and admin/config.php is causing the Vbulleting Header functions to kick in causing the conflict with my header.php.

              But no idea how to fix it.

              Comment


              • Actually the problem is with cookies. there is no header.php and footer.php
                Last edited by Goldfinger; Sat 15th Sep '01, 4:24am.

                Comment


                • Hmmm ... thats a point ...

                  My error occurs on line 1459 ... which is "setcookie($name,$value,$expire,$cookiepath);" Below

                  PHP Code:
                  // ###################### Start vbsetcookie #######################
                  function vbsetcookie($name,$value="",$permanent=1) {
                    global 
                  $cookiepath,$cookiedomain;

                    if (
                  $permanent) {
                      
                  $expire=time() + 60*60*24*365;
                    } else {
                      
                  $expire 0;
                    }
                    
                    if (
                  $cookiedomain) {
                      
                  setcookie($name,$value,$expire,$cookiepath,$cookiedomain);
                    } else {
                      
                  setcookie($name,$value,$expire,$cookiepath);
                    }
                    

                  Comment


                  • I know for a fact its a cookie problem because when you are logged into your board it'll work. But when you delete your cookies from your browser it'll be messed up.

                    Comment


                    • I think I know how to fix this (long time since I worked with cookies)

                      Add the following to the top of the index.

                      PHP Code:
                      <?
                      require("forum/fnqglglob.php");
                      require(
                      "forum/fnqglconfig.php");
                      require(
                      "forum/admin/config.php");
                      ?>
                      Before the require("layout/header.php");

                      The cookies from memory have to be loaded before the first < html > tag.

                      Mind you my memory is sad.

                      Comment


                      • doesnt work.
                        Last edited by Goldfinger; Sat 15th Sep '01, 4:37am.

                        Comment


                        • Yep ... fixed it ...

                          On my index I simply added the 3 includes before my header include.

                          Cookies have to be loaded prior to the first < html > tag (I am positive, but quite often wrong)

                          Comment


                          • Originally posted by Goldfinger
                            doesnt work.
                            Hrm ... wierd ...

                            Worked on my end ...

                            Those includes must be loaded before ANY html is parsed.

                            Comment


                            • try deleting your cookies. because it wiill work if logged onto your board. cause your coookies are still there.

                              Comment


                              • I did ... closed browser the works ...

                                It fixed it for me ...

                                http://www.fnqgl.com/testindex.php You can go there for a test.

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X