Announcement

Collapse
No announcement yet.

Will new PHP and MySQL break vBulletin 2.3.4?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Will new PHP and MySQL break vBulletin 2.3.4?

    I want to upgrade my server to the minimum requirements for the new vBulletin....

    System Requirements
    Minimum
    PHP 4.3.3
    MySQL 4.0.16

    Yet on my server I also run an old vBulletin 2.3.4 which I will NOT be upgrading to the new vBulletin.

    My current PHP is already... (PHP 4.3.8) so I should be OK there, but my current version of MySQL is.... 3.23.58

    Will upgrading my MySQL to 4.0.16 break my old vBulletin?

  • #2
    Actually my hosting company would like to perform the following upgrade....

    PHP can be upgraded to 4.3.11 and MySQL to 4.1.21

    Will that upgrade break my old vBulletin 2.3.4?

    Comment


    • #3
      I would suggest upgrading to php 4.4.4, I'm not sure if vBulletin 2.3.4 will run with MySQL 4.1.21. I'm fairly sure it will but I'm not 100%, off the top of my head i cannot think of anything in MySQL 4.1 that would break vB 2.

      Comment


      • #4
        Hi,

        I am running vBulletin 2.3.x with Apache/1.3.34, PHP 4.4.2 and MySQL 4.1.21-standard, and it is working fine.

        My question is: will MySQL 5.x and/or PHP 5.x break vbulletin 2.3.11?

        Thank you in advance.
        LaPiba

        Comment


        • #5
          Yes, I'm pretty sure it vBulletin 2.x won't work with such new versions of MySQL / PHP.
          Best Regards
          Colin Frei

          Please don't contact me per PM.

          Comment


          • #6
            Why don't you run dual PHP/Mysql? It's hard, but I have done this before.

            Comment


            • #7
              Originally posted by LaPiba View Post
              Hi,

              I am running vBulletin 2.3.x with Apache/1.3.34, PHP 4.4.2 and MySQL 4.1.21-standard, and it is working fine.

              My question is: will MySQL 5.x and/or PHP 5.x break vbulletin 2.3.11?

              Thank you in advance.
              Most likely
              Last edited by MRGTB; Fri 3rd Aug '07, 1:30am.

              Comment


              • #8
                I am running vBulletin 2.3.3 on PHP v5.2.6/MySQL v4.1.22, and so far there are no problems.

                Comment


                • #9
                  Frankly I'm surprised because you will definitely have problems with vB 3.0. Maybe vB2 is not sophisticated enough for newer versions of PHP and MySQL to break it.
                  Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                  Change CKEditor Colors to Match Style (for 4.1.4 and above)

                  Steve Machol Photography


                  Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                  Comment

                  widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                  Working...
                  X