Announcement

Collapse
No announcement yet.

[RELEASE vB 2.0.1] Image Gallery v1.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #46
    Originally posted by Sarge
    almost

    The thumbnails will not work

    http://www.dlrarmy.com/forums/gallery.php

    I have imagemagic installed BTW
    Is the path to convert set correctly in the config?

    Are you running in safe mode?

    Comment


    • #47
      it si the bsic red hat linux install and it works cause I use imagefolio


      HOw could I tell if the path is incorrect?

      Comment


      • #48
        Originally posted by Sarge
        it si the bsic red hat linux install and it works cause I use imagefolio


        HOw could I tell if the path is incorrect?
        At a shell prompt:
        rpm -ql ImageMagick | grep convert

        The setting I use by default is:
        /usr/X11R6/bin/convert

        Comment


        • #49
          do you have a prompt for telnet?

          Comment


          • #50
            My thumbs arent making their way into the thumbs table but im getting the processing messages.

            http://www.iguanaland.com/vbforums/gallerydebug.php

            Can anyone help?

            Comment


            • #51
              /usr/X11R6/bin/convert


              Is my path....

              It is right in the options.. still looking at broken thumbd.

              HELP!

              Comment


              • #52
                Did you telnet yet?

                Originally posted by mojotim
                Telnet in and go to a directory where you have some images.

                Then type this:

                convert -geometry 120x120 filename.jpg new_filename.jpg

                this will create a thumb 120x120 of filename.jpg

                You say you have ImageMagick but no thumbs to prove it. Try to do this telnet operation and see if it works.

                Comment


                • #53
                  If thumbs aren't making into table...

                  Please check to see if you're running in safe mode.

                  An easy way to do this is to create a file called phpinfo.php. It should contain these 3 lines:

                  <?php
                  phpinfo();
                  ?>

                  Put it in your forums directory and point your web browser at it. If you search for 'safe_mode', you should find 2 lines. safe_mode and safe_mode_exec_dir. If safe_mode is on, then safe_mode_exec_dir HAS to contain your a copy of convert. If you don't have shell access/admin access to your server, I doubt you will be able to make this change.

                  Comment


                  • #54
                    safe_mode
                    Off Off

                    http://www.dlrarmy.com/forums/phpinfo.php

                    Comment


                    • #55
                      Safe mode off/off here too and images still not making it into the table.

                      http://www.glidetech.com/phpinfo.php

                      Comment


                      • #56
                        Originally posted by TechTalk
                        Safe mode off/off here too and images still not making it into the table.
                        Is the filedata field in the thumb table blank? Trying to figure out if the error is in making the thumbs or just displaying them.

                        You can also try remarking out this line in functions.php:

                        unlink($thumbname);

                        Just put a // at the start of the line.

                        Then make a dumby post, with a BMP/JPG/GIF attachment. If ImageMagick part is working, it'll create a file:
                        /tmppath/th_[randomstuff].

                        /tmppath is most likely /tmp, but may vary.

                        Comment


                        • #57
                          My problem is with it being added to the DB. Looking at it thru phpmyadmin there are no records there.

                          I guess I will try the thing you mentioned above, although im not sure what difference that will make

                          ~Chris

                          Comment


                          • #58
                            OK just tried that. The th_ files are showing up each time i post an image. They are all 0kb though

                            Comment


                            • #59
                              Another note. Running the gallerymakethumbs.php file also puts a temp file in the tmp directory for each attachment i have (all 0KB) but still nothing in the DB

                              ~Chris

                              Comment


                              • #60
                                Originally posted by TechTalk
                                Another note. Running the gallerymakethumbs.php file also puts a temp file in the tmp directory for each attachment i have (all 0KB) but still nothing in the DB

                                ~Chris
                                Ok, what version of ImageMagick do you have installed? If it's RedHat, should be able to just: rpm -q ImageMagick at the command prompt.

                                If it's older then 5.3.3-2, let's try simplifying your convert statment. In functions.php, find this line:

                                PHP Code:
                                system("$galleryconvert -geometry '160x120>' $path -flatten -quality '75' JPEG:$thumbname"); 
                                and change it to
                                PHP Code:
                                system("$galleryconvert -geometry '160x120>' $path -quality '75' JPEG:$thumbname"); 
                                The -flatten parameter "flattens" out animated GIFs. Otherwise, convert tries to make a JPG for each frame of the GIF. 10 frames = 10 files, makes a real mess in the /tmp directory.

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X