Announcement

Collapse
No announcement yet.

[RELEASE vB 2.0.1] Image Gallery v1.0

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [RELEASE vB 2.0.1] Image Gallery v1.0

    Instructions in the ZIP file (gallery.txt). Should explain most details of installation. I haven't done an INSTALL from scratch, so you get to beta test that part of the program.

    The gallery itself seems quite stable. I added some load limiting/checking options before releasing as well. Let me know how your installs go, features you'd like to see, etc.

    If you want to see an example:

    http://www.noows.com/gallery.php?s=&forumid=88
    Last edited by Zamtil; Fri 29th Jun '01, 9:35pm.

  • #2
    Didn't realize how much GIFs sucked.

    Hadn't really explored the differences between JPG and GIF. I figured the files were so small, that file size wouldn't be much difference.. boy was I wrong. This is an updated copy that uses JPEG compression instead of GIF. If you've already install this hack, just replace the files, use a SQL tool to "DELETE FROM thumb" and rerun admin/gallerymakethumbs.php.

    In the future I may make thumbnail type a config option, but when I saw 20k thumbnails go to 3-5k, I decided quality was a mute point.

    The main change is this line in functions.php:

    PHP Code:
    system("$galleryconvert -geometry '160x120>' $path GIF:$thumbname"); 
    to

    PHP Code:
    system("$galleryconvert -geometry '160x120>' $path -quality '75' JPEG:$thumbname"); 
    Last edited by Zamtil; Sun 1st Jul '01, 5:51pm.

    Comment


    • #3
      just another thing, what font and settings did you use for the gallery button ? mind attaching the psd file for it too
      :: Always Back Up Forum Database + Attachments BEFORE upgrading !
      :: Nginx SPDY SSL - World Flags Demo [video results]
      :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

      Comment


      • #4
        you forgot the thumb.php in the zip file!
        Sorry for my bad English, i comes from germany!

        Comment


        • #5
          Originally posted by eva2000
          just another thing, what font and settings did you use for the gallery button ? mind attaching the psd file for it too
          It's the exact buttons from the vBulletin 2.0 graphics development kit. I just edited one of the top_ templates and the find template. Changed the word to gallery. Actually, I didn't even save the Photoshop version, just the exported GIFs.

          Comment


          • #6
            Originally posted by Znaper
            you forgot the thumb.php in the zip file!
            Yep, you're right. The ZIP is now: JPEG thumbnails + thumb.php. About 8 people got ahold of the original GIF version, I'd suggest switching to this.

            Comment


            • #7
              Anyone have it working yet? =)

              Would like to see it on someone else's site, post URL please.

              Comment


              • #8
                problem...

                Hey, great hack, but I'm having problems.

                Parse error: parse error in /usr/local/xxxxxx/httpdocs/admin/galleryinstall.php on line 17

                Looks ok to me, but I keep getting this.
                Using, Apache, RedHat Linux 7

                -Tim

                Comment


                • #9
                  Re: problem...

                  Originally posted by mojotim
                  Hey, great hack, but I'm having problems.

                  Parse error: parse error in /usr/local/xxxxxx/httpdocs/admin/galleryinstall.php on line 17

                  Looks ok to me, but I keep getting this.
                  Using, Apache, RedHat Linux 7

                  -Tim
                  Change line 17 to this:

                  PHP Code:
                  $DB_site->query("INSERT INTO setting VALUES (NULL,$groupid,'Pages to show in nav bar','gallerynavpages','5','','',1)"); 
                  Looks like there's an extra ") at the end of the line in the released file.

                  Comment


                  • #10
                    great that worked but...

                    Got a new one:

                    Warning: Division by zero in /usr/xxxxx/httpdocs/gallery.php on line 108

                    Should there be an "@" somewhere in there?

                    Comment


                    • #11
                      never mind...

                      I had the Gallery Load Limit
                      set to the default. I erased the value and the error does not come up now.

                      Comment


                      • #12
                        um, I must be screwing something up here

                        Check out this attachement and tell me if something should be in the filedata, value box.

                        I also go to the /gallery.php and see no attachments. I see nothing but the blank template.

                        Comment


                        • #13
                          here is what the gallery.php page looks like

                          Here is the entire substance of my gallery.php page.

                          Comment


                          • #14
                            Have you run yourforums.com/admin/gallerymakethumbs.php? It should spit out a list of file names for all the JPG/BMP/GIFs it finds in your existing attachment table.

                            Comment


                            • #15
                              yeah, got a nice blank page

                              I had to modify it a little:

                              makeThumb($thumb[attachmentid], $thumb[filename], $filename);
                              unlink($filename);
                              set_time_limit();
                              }
                              ?>

                              notice the change of set_time_limit();

                              I'm using safe mode php so it didn't like that.

                              Anyhoo, I get a blank page. I have attachments, I even (just now) posted a new attachment and ran gallerymakethumbs.php.
                              Still the blank page.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X