Announcement

Collapse
No announcement yet.

[RELEASE v2] Today's Events on Main Forum Page

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • SysMom
    replied
    Jakeman:

    I did move it to the header, and regretted it.

    Although it works FINE in displaying the event for that day, it 'breaks' your calendar, and you can only have one event per day, the last one that was entered.

    I suspect a variable is being tromped on, but I haven't looked into it.

    So, when I did the 2.03 update, I didn't put it back in the header, and I'm ... gonna get around to it someday, but I don't think I have the luxury of breaking two events on any day just now.

    -deb

    Leave a comment:


  • butty
    replied
    what a great hack, a doddle to install and so effective

    good work!!!

    Leave a comment:


  • Jake Bunce
    replied
    just installed v4. first time using this hack. works great.

    two comments:
    1) it would be nice to have a condition where if there are no events for that day it says 'none', or something to that effect.
    2) i too would like to have this functionality in my header. i didn't see any 'how to' things in this thread for that.

    on the same note. what php file controls functionality in the header?

    Leave a comment:


  • mister
    replied
    i just tested it out on my board

    2.0.3 w/this todays-events hack.

    worked fine.

    two events.
    both on calendar
    both on main page

    maybe re-upload calendar.php, make sure you have 2.0.3's version (not to say it isnt there already...but just in case)

    Leave a comment:


  • SysMom
    replied
    Is it just me, or is there only one event allowed per date?

    I don't know if it might be related to the Today's Event addition, but I suspect it isn't.

    I try to add a second event to the calendar, it takes the place of the first, the previous one does not appear on either the calendar, or the Today's Events listing.

    I upgraded to vb2.03 the other day, if that matters. Although I don't recall scheduling more than one thing before anyway.

    -deb

    Leave a comment:


  • CCarissa
    replied
    D'oh.....sorry, twas a typo

    Leave a comment:


  • mister
    replied
    Originally posted by CCarissa
    Here's line 69....
    i think i was confused by that

    Leave a comment:


  • CCarissa
    replied
    Im still pretty sure i posted line 79. *confused*

    Thanks. I'll try that tonight when the board isnt busy.

    Leave a comment:


  • mister
    replied
    ok well

    you pasted line 69... i'd need to see line 79 if the error was on line 79


    all you have to do to index.php is

    after this:

    PHP Code:
    if ($displayloggedin) { 
    add this:

    PHP Code:
    require('./todaysevents.php'); 


    my guess is either you mistyped that, or there was a problem copy/pasting it.

    also, make sure that todaysevents.php is in the same directory as index.php (the main vbulletin dir)

    Leave a comment:


  • CCarissa
    replied
    It was line 79......and darn it if i didnt save the error message. And i dont want to interrupt my users now.

    Lets see if i can remember it. I think it was something like, "there is a parse error on line 79 of index.php"

    Leave a comment:


  • mister
    replied
    can you also paste the error

    (and did you mean line 69 or 79?)

    Leave a comment:


  • CCarissa
    replied
    Here's line 69....

    PHP Code:
       $birthdays $DB_site->query_first("SELECT template FROM template WHERE title='birthdays' and templatesetid = -2"); 
    its a few lines under the new stuff......
    PHP Code:
      $birthdays gettemplate('birthdays',0,0);
      
    $btoday explode('|||',$birthdays);
      
    $today vbdate("Y-m-d",time()); 
    I really appreciate people looking at this for me.
    Last edited by CCarissa; Sun 29th Jul '01, 8:35pm.

    Leave a comment:


  • mister
    replied
    paste line 79 of your code into a reply, and we'll see whats happening....

    Leave a comment:


  • CCarissa
    replied
    I tried to install this with no success.

    When i try to access my forum I get an error on line 79 of my index.php file.

    What did i do wrong?
    Last edited by CCarissa; Sat 28th Jul '01, 4:04pm.

    Leave a comment:


  • Dave#
    replied
    just a gentle bump

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X