Announcement

Collapse
No announcement yet.

submitting a posts takes forever!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • submitting a posts takes forever!

    why is it when my friends or I submit a posts it takes so long, its not like its even going thru, i waited 5 almost 10 minutes but nothing happens. This hasn't happened before. All of a sudden it started to happen for some strange reason, the board works ok, Just cant submit a posts for some weird reason. Help plz!

  • #2
    same thing is happening to me

    happened to me before too
    posted a huge thread about it but no one really cared
    then all of the sudden it cleared up

    now it's back.

    i dont know what to do to fix it either, it's not a database problem

    i wish one of the vb devs would contact me to fix this nasty bug... icq @ 1483847

    Comment


    • #3
      With all due respect, this doesn't sound like a bug. Rather it sounds like a server problem. You'd be better off contacting your host about this.
      Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
      Change CKEditor Colors to Match Style (for 4.1.4 and above)

      Steve Machol Photography


      Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


      Comment


      • #4
        Same Here

        I had the same problem when I first set up vBulletin 2.0 using RC 1.1

        When I upgraded to the shipping version of 2.0 the problem mysteriously went away.

        Sometimes the delay was so bad the script timed out and didn't post.

        Comment


        • #5
          I've been running vB 2 since beta 3 and this has never happened to me. I have had extreme slow-downs from time to time, but this has always been related to problems on the server - not vB itself.
          Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
          Change CKEditor Colors to Match Style (for 4.1.4 and above)

          Steve Machol Photography


          Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


          Comment


          • #6
            this is the error msgs my friend got when trying to submit a post

            escription: Too much time has passed without sending any data for document "http://forums.ax.net/vb/newreply.php".

            Comment


            • #7
              Still sounds like a server problem to me.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                i think it was freddie, wayne or Ed who said, that posting a reply or thread is the most server intensive of all vB functions so for long threads or posts etc it can have a delay..

                from that and the above error i think it could be a server problem or a php timeout problem ?
                :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                :: Nginx SPDY SSL - World Flags Demo [video results]
                :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                Comment


                • #9
                  i had the same problem (it took like 1 minute to submit). some one else said they also had that problem and when they turned off e-mail notification for posts and threads the problem went away. so i also turned of e-mail notification and the problem went away. To turn it off you just have to take out that check box from the new posting templates.

                  Comment


                  • #10
                    Yes, if you have a long thread, we've discovered that PHP's mail() function seems to go pretty slowly. I know Me2Be's server was having load spikes and it was traced down to the email notifications.

                    Talking directly with the mail program could definately fix it, although it's not the most secure solution -- there will most likely be a vbmail() function in the future, so it would be easier to address if you desired...

                    Comment


                    • #11
                      ed, that's not it

                      and it's not a server problem.. trust me

                      any chance i can give you an account to investigate what's going on?

                      this is the SECOND time it's happened to me!

                      Comment


                      • #12
                        i found out, its a mysql server problem.... thats it!

                        Comment


                        • #13
                          i found php 4.0.6 solved it for me ;D

                          Comment


                          • #14
                            Originally posted by Mortin
                            i found php 4.0.6 solved it for me ;D
                            nice

                            Comment


                            • #15
                              If it's email related it seems like your machine must be configured to deliver email immediately instead of in the background. Otherwise calling sendmail to send mail would cause no delays, and turning off email wouldn't help.

                              You can check sendmail.cf to see if that gives you any clues. Try

                              grep Deliver /etc/sendmail.cf
                              grep Deliver /etc/mail/sendmail.cf

                              it might be in one of those locations. See if it's set to "immediate". It should probably be set to "background". You can override it in your php.ini, put the sendmail path from "somepath/sendmail -t -i " to "somepath/sendmail -t -i -ODeliveryMode=background" I believe it is. (Your setup might not use -i...)

                              If it's email related that might solve it. If your box uses qmail there some other command you can put as the sendmail_path to inject the mail into the qmail system.

                              The point is, sending mail through php should NOT require php to wait until the email is delieved. However, it normally just runs sendmail -t and if sendmail.cf is set for immediate delivery, that can cause sendmail to tie up the calling process...

                              Or heck you can try the -O option regarldess and see if it helps.

                              -Jonathan

                              Comment

                              Related Topics

                              Collapse

                              Working...
                              X