Announcement

Collapse
No announcement yet.

not logged in user's timezone

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • not logged in user's timezone

    I don't know if this is a bug or the way it's suppose to work. So I thought I'd post my question here and get some feedback from fellow vBulletiners.

    Just this afternoon I upgraded from 1.1.6 to 2.0.1 and it went great. Took forever for me to change the colors and templates and such but it's all done now (I think).

    Here's the deal though... in the admin control panel, I set my server's time zone as GMT -5. On my forums opening page, it says that all times are given in GMT. When a user logs in, that changes to whatever their local time zone is. That's good. But what I don't get is why a non-logged in user sees the time GMT rather than my server's time which is GMT -5. Does that make any sense?

    Is there any way that I could have non-logged in users see the times posted as GMT -5 rather than GMT?

    Thanks
    -Mark
    Live Weather Images
    http://www.WeatherImages.org
    forums @ http://www.weatherimages.org/forums/

  • #2
    In sessions.php, look for a line that should look like this:

    $bbuserinfo['timezoneoffset']=0;

    The part you want to change to -5 is in blue.

    Comment


    • #3
      Thanks for the super-quick response! That took care of it! Thanks again
      -Mark
      Live Weather Images
      http://www.WeatherImages.org
      forums @ http://www.weatherimages.org/forums/

      Comment


      • #4
        If I change it to -1 it shows correctls "All times are WEZ -1 hours", but if I set it +1 it just shows "All times are WEZ 1 hours"

        the "+" is missing!

        where can i get it?

        Comment


        • #5
          Originally posted by Ed Sullivan
          In sessions.php, look for a line that should look like this:

          $bbuserinfo['timezoneoffset']=0;

          The part you want to change to -5 is in blue.
          Where is "sessions.php"? I looked in FTP, and couldn't find it.

          Steve

          http://www.jumpondeals.com
          http://www.jumpondeals.com/forum

          Comment


          • #6
            admin/ directory.

            Comment


            • #7
              Í´m still searching for the lost "+" (see above)

              Comment


              • #8
                Thanks Ed! I found it.

                The only problem I still have is for users when they're logged in. It shows up as Central Time, because my server is on Central Time, and I had to set it in the control panel for GMT -6.
                Is there anyway that I can change the default time zone for EXISTING users to EST.
                I have set the default time for new users EST. But I found no solution for existing users.

                Steve

                http://www.jumpondeals.com
                http://www.jumpondeals.com/forum

                Comment


                • #9
                  /me is still asking for the not showing "+"

                  If I change it to -1 it shows correctls "All times are WEZ -1 hours", but if I set it +1 it just shows "All times are WEZ 1 hours" Without any "+" before the 1!

                  Comment


                  • #10
                    $bbuserinfo['timezoneoffset']="+1";

                    Comment


                    • #11
                      yesssss, that works, thanks!

                      Comment


                      • #12
                        I figured it out. PLease ignore
                        Last edited by Boss; Sat 23 Feb '02, 4:07pm.

                        Comment

                        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                        Working...
                        X