Announcement

Collapse
No announcement yet.

Problem With Private Messaging Totals

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Problem With Private Messaging Totals

    Went to my forums and got told I had a new message, no worries - I went and read it.

    I browse the forums, reload the front page, and see the following:

    You have 1 new message
    (You have 0 unread messages and 5 total)

    Now as it turns out the "1 new message" is the one I've already read. Okay so it for some reason forgot that, so I go check and sure enough it IS marked read. So now I'm interested, first it's saying I have an unread message.... yet it is ALSO saying at the very same time that I have 0 unreads.... ya what???

  • #2
    The meaning of 'new' and 'unread' is subtlely different.

    A 'new' message is one that you have received since you last logged in.

    An 'unread' message is one that you have not yet read.

    John
    John Percival

    Artificial intelligence usually beats real stupidity ;)

    Comment


    • #3
      But when you go to the front page of your control panel, it differs - it says there are "no new messages since your last visit". Go back to the front page, and it still says there is "1 new message since your last visit".

      Comment


      • #4
        Current status -


        Forums Front Page: You have 2 new message(s) since your last visit.

        Control Panel Front Page: You have not received any private messages since your last visit to DVD Plaza.


        Note that I have read all the new messages in my inbox.

        Comment


        • #5
          Yeah I see what you mean. It should say "No unread messages" in the User CP, because that's really what it's talking about.

          Comment


          • #6
            I had this problem once. If you want to know how to fix this, send me a PM. I wrote a PHP script to recalculate PM totals and adjust them for each user.

            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X