Announcement

Collapse
No announcement yet.

Not Creating Cookies!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Marco van Herwaarden
    replied
    A major upgrade like this will require some work on your side on the style. I suggest you setup a test board with a copy of your current board, run a test upgrade and remake a style for the new version. Once you are satisfied, you can export the style from your test boad, upgrade your production board and import the new style.

    Leave a comment:


  • JakeS
    replied
    Take a full backup, then upgrade so then if it goes wrong, you can just restore backup.

    Leave a comment:


  • Steve Machol
    replied
    Yes, upgrading will retain your data - users, posts, etc. Otherwise there would be no poiint in upgrading at all.

    You will have to redo your styles since the vB2 templates are not compatible with later versions.

    Leave a comment:


  • ShakiraFuego
    replied
    Originally posted by Steve Machol View Post
    Import what into what?
    Well, I meant importing the most recent backup to the old host.

    Unfortunately, I discovered today that the forum was running on a version of mySQL much older than what I was originally told (3.8.x). My new host moved me at my request from a server running 4.1.21 to 4.0.x, and while it fixed one mySQL error that I kept receving, it did not fix the cookie issue.

    My new host will be updating all of their servers within the next 8 months to the most recent mySQL, and my old host is flat out unreliable. I'm frustrated beyond wit's end now, because I have come to the conclusion that no matter which route I go, I HAVE to upgrade sooner or later.

    Will the upgrade from 2.3.2 to 3.0 keep my userbase and threads, or will I have to start from scratch? Will the styles remain? Will I be able to customize it to look as CLOSE as possible to 2.3.2? The forum and its styles are visible here: http://board.shakiraholics.com

    Leave a comment:


  • Steve Machol
    replied
    Import what into what?

    Leave a comment:


  • ShakiraFuego
    replied
    I did what was suggested, and did a test install of both versions 3.0.x forum and 2.3.5. 3.0.x worked just fine, created cookies and all. 2.3.5 would not even make it past the 4th install step, which tells me it IS running on a version of mySQL that is only supported from 3.0.x onward.

    I don't care for the 3.0.x interface and neither do my users (to me it too much resembles the look of invision), so my only choice is to have it run on the old host. Since I already paid for a year of hosting on the new host, I'll just be running the site itself there, and the forum on the old one. SIGH.

    Now, a final question: the old forum is about one month old. How would I update it to the current backup with the new users and posts without messing anything up? It's not really a "transfer" as so much maybe an import? I'm not sure.

    Leave a comment:


  • Marco van Herwaarden
    replied
    This could be caused by a Hardened patch installed for PHP. You could check the PHP-Info for both old and new server for settings that are different.

    Also i would suggest you install a new version of vBulletin into a test directory/database and see if that install does work correct.

    Leave a comment:


  • Colin F
    replied
    In your vBulletin Options, check the cookie domain and cookie path settings and set these to (blank) and / respectively.

    Leave a comment:


  • ShakiraFuego
    replied
    Originally posted by Colin F View Post
    Possibly vBulletin 3.0.x would work, but if you're upgrading it makes sense to just go the whole way, as it's not really more work.
    Actually, I did a little more research on this, and my old host is running the same versions of PHP and MySQL. The site is currently mirrored there, and works just fine. Other vBulletin forums that I frequent have the same versions as well, and using 2.3.2, create cookies without any problem.

    I even proposed the idea of an upgrade to my forum users, but they don't want to face any more problems or big design changes.

    I am really stumped with this problem now.

    Leave a comment:


  • Colin F
    replied
    Possibly vBulletin 3.0.x would work, but if you're upgrading it makes sense to just go the whole way, as it's not really more work.

    Leave a comment:


  • ShakiraFuego
    replied
    If upgrading is my only option then, what is the lowest version I can use to fix my problem? 2.3.x would be the best for me, because I do not want to change the look of my forum, especially when it has 5 styles. Will upgrading get rid of my userlist, their threads and posts?

    It just seems like so much work for something that has worked on the old host for the past 4 years. I am also afraid that if I attempt the upgrade, I'll screw something up.The new host is running PHP 4.4.2 and MySQL 4.1.21.

    Leave a comment:


  • Steve Machol
    replied
    Honestly it's time to upgrade. The most likely cause is that this ancient version of vB is not compatible with the newer versions of MySQL and PHP that are running on the new server.

    Leave a comment:


  • ShakiraFuego
    started a topic Not Creating Cookies!

    Not Creating Cookies!

    I have an issue with VB 2.3.2. I have been running my forum for almost 5 years and have never had this problem occur. I moved to a new host last week, made no changes (other than the necessary username/dbname/passwords), and after all of the DNS problems have been resolved, this issue still occurs.

    The forum is NOT creating cookies at all. The only users who can login are those who have cookies from before the server move. The users who don't have the cookies can't even create them. Any link on the forum resets the user and they are recognized as not logged in. No cookie shows up in their list. This also happens to me too. And, when I attempt to login to the admin console, the page refreshes after my info is entered, but I am not logged in. The only difference is the main login page only refreshes itself, and there is a side frame that opens up showing the main login page as well, instead of the control panel.

    Help is desperately needed! Again, nothing has been changed or altered, and it is affecting EVERY soul who has cleared cache, cookies, and restarted their browers since the site transfer.
Loading...
Working...
X