Announcement

Collapse
No announcement yet.

Please help with my config.php....i am going nuts!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Please help with my config.php....i am going nuts!

    I have spent 8 hours+ trying to get my config.php set up for use on my new easypace.com account.

    I have the forum running on a spaceports account at present and that was my first ever experince of MySQL/PHP etc. and I was really happy with the way vbulletin installed with ease!

    BUT because spaceports is too slow I decided to pay £150 UK for 200mb webspace /php/mysql etc. with easyspace....in short they have been CRAP! They never answer my emails and now I am under pressure to get this up and running!

    Maybe another easyspace user wil be able to help:

    Database name???? < normally same as username
    Database server type?? <set to 'mysql' at present
    Database server host name????< tried everyhthing imaginable!

    PLEASE...PLEASE Help!

  • #2
    hmm ...

    i have known easyspace to be crap too. You couldve got much better deals for 150£

    anyway, try putting server host name as "localhost" without the "

    If that doesnt work, make sure there IS a mysql database created in cp or sumthing

    I hope it works for u mate, I know how stressing it can be

    Comment


    • #3
      btw, if all this fails, u can always send me the config.php file u think is supposed to be correct and I could have a quick look over.

      Comment


      • #4
        Thanks for the quick reply (unlike easyspace who have not replied to 3 emails over 3 days)....I have tried "localhost" as server host name but with no sucess just the following message:

        Warning: Can't connect to local MySQL server through socket '/tmp/mysql.sock' (111) in /www.starchipforums.com/forums/admin/db_mysql.php on line 38

        Warning: Supplied argument is not a valid MySQL-Link resource in /www.starchipforums.com/forums/admin/db_mysql.php on line 47

        The database has failed to connect because you do not have permission to connect to the server. Please go back to the last step and ensure that you have entered all your login details correctly.

        my config.php settings are

        // type of database running
        // (only mysql is supported at the moment)
        $dbservertype="mysql";

        // hostname or ip of server
        $servername="localhost";

        // username and password to log onto db server
        $dbusername="username as per ftp login";
        $dbpassword="password as per ftp login";

        // name of database
        $dbname="same as username";

        // allow password viewing / editing in control panel
        // 0 = not visible or editable
        // 1 = not visible, but can be edited
        // 2 = visible and can be edited
        $pwdincp=0;

        // technical email address - any error messages will be emailed here
        $technicalemail = "[email protected]";

        // use persistant connections to the database
        // 0 = don't use
        // 1 = use
        $usepconnect = 1;

        ?>

        Any ideas???

        Comment


        • #5
          Well, either MySQL is down or MySQL isn't even running on that server.

          Unfortunately, there's not a ton we can do -- you'll have to get/confirm your MySQL details with your host.

          Comment


          • #6
            Thanks....

            I paid for mySQL/PHP/CG...and.and.and.

            I am under real pressure to move my board somewhere NOW because spaceports is just TOO slow....I went with paid (easyspace CRAP) because I needed a professional image....can u suggest a temporary free host that's not too much hassle to configure and I can have up and running today.....you will see that www.starchipforums.com is WAY too slow.

            By the way.... you must have other registered board owners using easyspace. Is it not possible to retrieve this data somehow???? long shot i guess!!

            AND OH - The support here is great....i wish every product/service I bought was like this....keep up the good work! THANKS!

            "I think I'll dispute my payment for easyspace if they don't answer me within the next 24 hours!"

            Comment


            • #7
              Please check with your host that you do have access to mySQL in your line above there is:

              "The database has failed to connect because you do not have permission to connect to the server"

              Which says it all, it looks like mySQL has not been setup for you to access. Perhaps give them a call?

              Comment


              • #8
                Thanks... I think you are right but in the easyspace account management it it says that php/sql in use!!!

                I HATE easyspace and will NEVER recommend them to anyone, particularly since they have NO telephone support and they make it hard enough for you to get to their email link!!!!

                Comment

                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                Working...
                X