Announcement

Collapse
No announcement yet.

Fatal error: Allowed memory size exhausted

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fatal error: Allowed memory size exhausted

    vBulletin 2.3.0 - Recently, when users try to upload files greater than about 1 mb as attachments, I have been getting the following error:

    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 2324150 bytes) in /home/cust1/username/html/forum/admin/db_mysql.php on line 281

    My service provider keeps telling me stuff like this:

    Thank you for contacting technical support regarding your issue. The error you reported indicates that your script is exceeding your PHP process memory limit on the server. Because these limits are in place to ensure the performance and stability of the entire server, we cannot modify them for your account. We apologize for the inconvenience. We recommend that you consult with your programmer or the developer of your application for suggestions on how to implement file uploads in a less memory-intensive fashion.

    In other words, blame it on somebody else.

    I could swear this was working up until recently. The forum has been running for several years. They swear up and down they haven't changed anything (but they've done it in the past and been wrong before).

    I verified with php_info():
    upload_max_filesize = 2 MB
    memory_limit = 8 mb
    post_max_size = 8 mb

    My max upload size in the forum settings is 3 mb.

    Anyway, I'm on a shared server, I don't feel like moving the site at the moment, any ideas what I can do?

  • #2
    Your host needs to increase the memory_limit setting in php.ini. Your forums are probably too big for the 8Mb limit. I recommend 16M at the least.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Thanks for the reply. Since they've already said they will not do it, is there anything else I can do, other than moving my entire web site?

      Comment


      • #4
        Honestly I don't know if this will work in vB 2.3.0 or not, but you can try adding this line to your config.php file right under <?php

        ini_set("memory_limit", "16M");

        Also you really need to upgrade. Not only are you terribly out-of-date but there are security issues in your version of vB.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by Steve Machol View Post
          Honestly I don't know if this will work in vB 2.3.0 or not, but you can try adding this line to your config.php file right under <?php

          ini_set("memory_limit", "16M");
          If I add this, and upload the new config.php file, do I need to do anything to get the changes to register?

          Also you really need to upgrade. Not only are you terribly out-of-date but there are security issues in your version of vB.
          I know. I already purchased an upgrade license to 3.x a few months ago. Just got side-tracked from doing the update. Also, scared.

          Comment


          • #6
            Adding that should affect this immediately, assuming it works at all with vB2.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X