Announcement

Collapse
No announcement yet.

Long delay after submitting a post.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    thx. But no one on my forums uses e-mail notification anyways. So I just disabled it. Besides, I don't have root access to mod the php.ini file.

    Comment


    • #17
      And does that solve your problems with delays when posting?

      -Jonathan

      Comment


      • #18
        it sure seems to have solved it.

        Comment


        • #19
          Ok. I'm sure it has to be waiting as each email is sent out, the question is why it waits at all. But you have a solution that solves your problem no need to mess further I guess.

          Have a great night,

          -Jonathan

          Comment


          • #20
            http://geekvillage.com/ubb/Forum3/HTML/002662.html

            Is relevant. If a dns lookup is slow or fails, it will cause delays in sendmail even with background processing turned on. For people having really slow posting because of email related issues, try adding -ODevelieryMode=q to the sendmail_path php variable. Then it'll just queue it, not even do a DNS lookup. I hesitated to recommend that before, because what if your box isn't set up to do any queue scanning at all?

            But it's worth a try...

            -Jonathan

            Comment


            • #21
              I'm also getting a very long delay after submitting a reply to a thread. In my case we are on a large dedicated UNIX server and have had no previous problems. In my PHP.ini file we have this...

              SMTP = localhost ;for win32 only
              sendmail_from = [email protected]ost.com ;for win32 only
              ;sendmail_path = ;for unix only, may supply arguments as well (default is 'sendmail -t -i')
              Has anyone got any idea why these random delays happen? What can I do to prevent them? Does my php.ini file need editing?

              Thanks!
              xlguy

              Comment


              • #22
                Ok, I just turned off the email functions through Admin Control Panel and the "Submit Reply" function now works really quickly. This is obviously some kind of bug with vBulletin on certain servers. Over 6 people have posted the same problem on this thread but no-one has offered a solution that works.

                So, can anyone from JelSoft help? What modifications do I need to make in order to have email functions but no long delays?!

                Please help me and everyone else


                DiscussFitness.
                xlguy

                Comment


                • #23
                  It may not be a vB bug. As discusssed before, sometimes mail delivery takes place on the server when you send the mail, and the sending program has to wait for it to complete. If there is a DNS timeout it'll delay the calling program (vBulletin). There were some earlier suggestions to work around it, but I don't have a clue what to try for a windows server. If you could reduce the DNS timeout maybe that'd be a workaround.

                  The best solution is to hand off the mail delivery to the local sendmail/etc system, and not send it immediately. Then only sendmail will get delayed once it tries to send it.

                  -Jonathan

                  Comment


                  • #24
                    I'm actually on a UNIX box! I don't quite understand why my PHP.ini file is set-up like this. How is yours set-up? Please could someone copy-paste their settings in here. It looks like my hosting company put the wrong .ini file?

                    Thanks!
                    xlguy

                    Comment


                    • #25
                      Add my name to this list. I've been fighting a "posting bug" on large threads for weeks, it would never post-just time out. Read this thread, turned off email notification and bug is gone.
                      Saint Stephen
                      Sysop, http://www.nachos.net

                      Comment


                      • #26
                        Hi all

                        Well im having a similar problem but after i hit submit the page takes for ever then i get page not displayed. No one on my forum has the same problem, so im thinking its just me. Iv delete cookies temp files, installed explorer again etc etc and still the same problem. The only way i get it to work is if i type (test) then submit and it works ok, i just go edit and type in my reply and done. It seems to be down to the amount of text. Iv even tried opera and still the same error. I have no idea what else i can do can anyone think of anything??

                        thanks

                        Beams

                        well it deff my end as iv just had to do it on here as well

                        Comment


                        • #27
                          Have you tried cleaning out the thread subscriptions? I had that problem with the threads hanging too and cleaned all of them out. Turns out I had about 123,000 thread subscriptions in there! I'm sure that was bogging things down a bit! I also turned off the popup pm notifications. That helped a lot too.

                          Hope this helps,
                          TigerLily

                          Comment


                          • #28
                            good suggestion. I did not even see that a clear subscription function until you mentioned it.
                            Saint Stephen
                            Sysop, http://www.nachos.net

                            Comment


                            • #29
                              Me Too.

                              I too have run into the same problem. Everything on the board is running fast and smooth. Our server load is like between 2.0 to 5.0 because we're a small private board.

                              Last week I started seeing that posts were taking forever to go through. Not all mind you, just the ones that were longer. PM's were fine, new messages were fast too.

                              So, I did a serch and found this thread. I went back to my board and turned off the e-mail notifications and lo and behold the speed is back..

                              So, assuming that this isn't a vBulletin bug, but a sendmail config issue, how can I change it? Is this something that requires root access?

                              Originally posted by roy7
                              By default if you don't override it, php uses

                              /usr/sbin/sendmail -t -i

                              to send email. This will, in fact, look up the remote domain's MX record and connect to deliver the email directly, while you wait. I'm looking into how to get sendmail to queue it instead. This is what is causing your delays I'm almost certain. Some of those servers might be down or slow, and sendmail sits and waits for it to finish.

                              Comment


                              • #30
                                Upping this thread, because I am having the same problems.

                                - it is defenitely a sendmail-problem
                                - setting "queue-only" through webmin doesn't seem to solve it. What is does do, is slow down mail-delivery
                                - removing the thread-subscription of the specific user solves the problem

                                Has anyone allready found the solution? Without turning off email-notification?
                                Dutch community site for single parents.

                                http://www.ouderalleen.nl/thuis.html

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X