Announcement

Collapse
No announcement yet.

Uploading attachments?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Uploading attachments?

    How do i upload attachments? I've tried everything. It says it was sucessful but then there is nothing there to let you download it

  • #2
    We need more info:

    PHP version (you can get the below by going to admin/index.php?action=phpinfo )
    -- safe_mode value?
    -- upload_tmp_dir value?
    OS

    Comment


    • #3
      PHP Version 4.0.5

      System Windows 95/98 4.90
      Build Date Apr 30 2001
      Server API CGI
      Virtual Directory Support enabled
      Configuration File (php.ini) Path C:\WINDOWS\php.ini
      ZEND_DEBUG disabled
      Thread Safety enabled

      This program makes use of the Zend scripting language engine:
      Zend Engine v1.0.5, Copyright (c) 1998-2001 Zend Technologies

      safe_mode
      Off Off

      upload_tmp_dir
      no value no value

      Comment


      • #4
        Edit your php.ini and set your upload_temp_dir to a directory with forward slashes and a trailing slash (like c:/temp/) and (if necessary) restart your webserver so PHP gets reloaded.

        Comment


        • #5
          No sorry, I added c:/windows/temp/ to the php.ini as you said and still nothing. I haven't changed any other options, they are still as default so I can understand why it isnt working.

          Comment


          • #6
            I tried that to and nothing happens, I change to the right vallues in php.ini, but it dont show any changes when i run the php info. weird.. Is there any one running win 98 who.s got it working, Please tell me how then, i am getting crazy soon

            Comment


            • #7
              If phpinfo() output doesn't show any changes, restart your computer.

              Comment


              • #8
                Originally posted by Jpp
                I tried that to and nothing happens, I change to the right vallues in php.ini, but it dont show any changes when i run the php info. weird.. Is there any one running win 98 who.s got it working, Please tell me how then, i am getting crazy soon
                If you are running PHP as and ISAPI module, you will have to reboot your machine for any changes to take effect under Windows 9X.

                If under NT and using IIS, you will have to end the IIS service and restart it. Sometimes this requires a reboot, sometime it doesn't.

                If you are using PHP as an Apache Module, you will have to restart Apache before any changes take effect.
                Translations provided by Google.

                Wayne Luke
                The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                vBulletin 5 Documentation - Updated every Friday. Report issues here.
                vBulletin 5 API - Full / Mobile
                I am not currently available for vB Messenger Chats.

                Comment


                • #9
                  Nop no changes after i restarted the computer, This is strange, when i configured the email settings it worked, But it says that default path should be used if no settings... is that C:\windows\Temp ?? What settings should it be on the board then, non?? just alow attachments. something got to be wrong here, I am using Omnihttpd server and everything else works just fine

                  Comment


                  • #10
                    Originally posted by Jpp
                    Nop no changes after i restarted the computer, This is strange, when i configured the email settings it worked, But it says that default path should be used if no settings... is that C:\windows\Temp ?? What settings should it be on the board then, non?? just alow attachments. something got to be wrong here, I am using Omnihttpd server and everything else works just fine

                    Is there anyone who knows why everything i change in php.ini shows up, but the download temp folder, it changes in the ini file but not in the info i run on the board


                    sql.safe_mode
                    Off
                    track_errors
                    Off
                    upload_max_filesize
                    5M 5M
                    upload_tmp_dir
                    no value no value
                    user_dir
                    no value no value
                    variables_order
                    EGPCS EGPCS
                    y2k_compliance
                    Off

                    Comment


                    • #11
                      Possibly because safe mode is off.
                      Last edited by Wayne Luke; Fri 1st Jun '01, 6:05am.
                      Translations provided by Google.

                      Wayne Luke
                      The Rabid Badger - a vBulletin Cloud customization and demonstration site.
                      vBulletin 5 Documentation - Updated every Friday. Report issues here.
                      vBulletin 5 API - Full / Mobile
                      I am not currently available for vB Messenger Chats.

                      Comment


                      • #12
                        Actually, you're probably changing the wrong php.ini then

                        I know I actually have 3 php3.ini's, but only the one in the same dir as php.exe is used.

                        Comment


                        • #13
                          Could it be so?? I changed the one in C:\windows but i found out that it had an ; in front of the line.. "upload_tmp_dir", changet it and got it to show up, but it still wont work, tried all slashes there is,

                          I dont think it is win 98!! maybe php or the Vb that is configured wrong, But it suposed to work with win98 to, so i think there is need for a pro to fix it, It is not only me who cries!!!!

                          Btw my php.ini in the php dir, is called php.ini-dist and php.ini-optimized and the one in windows dir is only php.ini
                          Last edited by Jpp; Fri 1st Jun '01, 12:08pm.

                          Comment


                          • #14
                            what about mysql?? is there any configurations to made there??

                            Comment


                            • #15
                              i get the same error
                              so plz help

                              Comment

                              Loading...
                              Working...
                              X