Announcement

Collapse
No announcement yet.

[release] Tiny hack: Custom nopermission message to unactivated users

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Grover
    replied
    Great! This HAS to be a standard-feature in VBulletin.

    Hi Mas*Mind,

    Are there plans to release this very useful hack in a future version of Vbulletin? I think that this HAS TO BE part of the standard VBulletin-features in the future: it is one of the most useful (and can I even say: NECESSARY) hacks I have ever seen.

    I hope they put it in! It really just saves us so much work........

    Grover.

    Leave a comment:


  • web
    replied
    It was my 1st hack installation

    Nice job. This was the first hack I installed since I start using vBulletin. It works fine with one exception. The link to go to 'profile' and edit the password did not work. It kept returning to the new 'not activated' page. Not a problem, I just removed that portion of the template. I also removed the portion for "forgot password." The user is already logged in, so they could not have forgotten their password .

    Thanks for sharing the work and it will definitely save me some time responding to emails and voice mails.

    Regards,

    web

    Leave a comment:


  • MarkB
    replied
    I finally got around to adding this to my forums, and it's been a godsend. Thanks!

    Leave a comment:


  • aldamon
    replied
    Great stuff! Thanks!

    Leave a comment:


  • pran
    replied
    great hack!

    Thanks Mas*Mind, great hack!

    Leave a comment:


  • JJR512
    replied
    I have taken the liberty of re-wording the new template, as well as adding a new part to it. The re-wording was done to improve the English a bit (and that is not said to be critical). I added a line to say that maybe the user supplied the wrong address, and should contact the webmaster if he/she still does not get the activation email.

    PHP Code:
    You have recently registered at $bbtitlebut have not yet activated your accountYou can find the link to activate your account in your welcome-email.

    <
    p align="center">
    <
    table border="0" bgcolor="#555576" cellpadding="4" cellspacing="1" align="center">
    $logincode
    </table>
    </
    p>

    <
    p><smallfont>If you haven't received the activation email, <a href="register.php?s=$session[sessionhash]&action=requestemail">click here</a> and it will be resent. If you still do not receive the activation email, you may have mistyped your email address. If you suspect you used the incorrect email address, please contact the <a href="mailto:[email protected]">Webmaster</a>. <a href="member.php?s=$session[sessionhash]&action=lostpw">Forgotten your password?</a> 
    Does anyone know the variable to use for the webmaster email, rather than hard-coding it as I have done?

    Leave a comment:


  • Alex
    replied
    Just installed it... works like a charm and (my oppinion) is a very helpful thing for User awaiting Email Confirmation. :-)

    Leave a comment:


  • jookido
    replied
    Thanks Mas! Was thinking of pouring through the code to get something like this to work, but you've done everything already!

    Great stuff.

    Leave a comment:


  • robertusss
    replied
    great one!

    this one must be in 2.1 - no doubt!
    Last edited by robertusss; Sun 10 Jun '01, 9:09am.

    Leave a comment:


  • Dakota
    replied
    I have to say that I like your hack too. Good Job

    Leave a comment:


  • Mas*Mind
    replied
    Glad y'all like it

    I slightly changed the error_nopermission_awaiting_moderation -template to make it even more clear:

    PHP Code:
    You have recently registered at $bbtitle but not yet activated your account
    You can find the link to activate your account in your welcome-email
    If 
    you didn't received the activation-email or you've allready deleted it, <a href="register.php?s=$session[sessionhash]&action=requestemail&email=$bbuserinfo[email]">click here</ato resend it to you're email-adress ($bbuserinfo[email]). 
    If you still don'
    t receive it thenyou probably have entered an incorrect addresyou can correct it by editing your <a href="member.php?s=$session[sessionhash]&action=editprofile">profile</a>.

    <
    p align="center">
    <
    table border="0" bgcolor="#555576" cellpadding="4" cellspacing="1" align="center">
    $logincode
    </table>
    </
    p>

    <
    p><smallfont><a href="member.php?s=$session[sessionhash]&action=lostpw">Forgotten your password?</a></smallfont
    then change

    <input type="text" class="bginput" name="email" size="35" maxlength="90">

    to

    <input type="text" class="bginput" name="email" size="35" maxlength="90" value="$email">

    in your activate_requestemail-template

    Leave a comment:


  • Castel
    replied
    Wow, didn't see this til now. Very useful Mas*Mind, I will install it shortly. Even after adding additional lines to the normal error template I still get mail daily about stuff like this. Great little hack!

    Leave a comment:


  • daydreamer
    replied
    No Problems...

    DUH! AGAIN... I need some sleep.

    Okay, As in my post earlier. I forgot to rename all file extensions to .php3

    I am usually very careful when doing so while using Note Tab Lite. Having said that, I rename all to .php33

    All is not my fault as that was the first thing I thought of to check, but the program's search feature did not find them. I had to locate them all myself. Only about nine or so.

    I will now reinstall Note Tab Lite....

    Mods, please delete my post here today

    dd

    Leave a comment:


  • daydreamer
    replied
    possible problems???

    Hello again,

    I think this hack may have caused some problems with links on showthread pages such as this:
    http://forums.dreamsweb.net/showthre...s=&threadid=12

    Notice the "general forums" and "Sales Questions" links at top. The refer to .php33 pages.

    Anyone who has installed this hack please check to see if you are having the same problem.

    Thankx

    dd

    Leave a comment:


  • daydreamer
    replied
    DUH!

    I didn't change the file extensions to .php3...

    dd

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X