Announcement

Collapse
No announcement yet.

No cache headers

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • No cache headers

    I have specifically set vBulletin NOT to use no-cache headers but they keep getting added to my templates:

    Code:
    	<!-- no cache headers -->
    	<meta http-equiv="Pragma" content="no-cache">
    	<meta http-equiv="no-cache">
    	<meta http-equiv="Expires" content="-1">
    	<meta http-equiv="Cache-Control" content="no-cache">
    	<!-- end no cache headers -->
    Any ideas?

    Example: http://forum.twilight-online.net

  • #2
    I believe no-cache-headers are always used for index.php, but the setting should be used for other pages.

    Comment


    • #3
      Thanks Chris.

      I had a look through the major templates and its only in forum home - it doesnt bother me - I just thought Id found some sort of bug

      Thanks for your time

      Comment


      • #4
        This is straignt from the Apache default httpd.conf.
        # CacheNegotiatedDocs: By default, Apache sends "Pragma: no-cache" with each
        # document that was negotiated on the basis of content. This asks proxy
        # servers not to cache the document. Uncommenting the following line disables
        # this behavior, and proxies will be allowed to cache the documents.
        #
        #CacheNegotiatedDocs
        Could this have anything to do with it, or is this something else?
        http://britishexpats.com/ - British expatriate community

        Comment


        • #5
          No Cache headers were added to the forumhome template to force Proxies to handle this document properly due to some proxies caching it and serving the stored pages to the wrong sessions.
          Translations provided by Google.

          Wayne Luke
          The Rabid Badger - a vBulletin Cloud demonstration site.
          vBulletin 5 API - Full / Mobile
          Vote for your favorite feature requests and the bugs you want to see fixed.

          Comment


          • #6
            Originally posted by wluke
            No Cache headers were added to the forumhome template to force Proxies to handle this document properly due to some proxies caching it and serving the stored pages to the wrong sessions.
            Does this apply to cookied-visits or only session-variable visits?

            I was under the impression proxies only stored based on the URL?

            Comment


            • #7
              Originally posted by fastforward
              This is straignt from the Apache default httpd.conf.
              CacheNegotiatedDocs: By default, Apache sends "Pragma: no-cache" with each document that was negotiated on the basis of content. This asks proxy servers not to cache the document. Uncommenting the following line disables this behavior, and proxies will be allowed to cache the documents.
              #CacheNegotiatedDocs

              This may be off-topic, but could this be why my forum graphics keep reloading while I'm surfing the forum? The graphics seem to reload when replying, editting, viewing a thread then hitting back, etc. - seems excessive reloading of graphics to me and I can't figure it out.

              Only happens on vB boards, not on any others, so it's not my browser settings (I'm set to "automatic" in IE 5.01).

              Comment


              • #8
                This is only on the forumhome template, meaning the only no-cache is forced is on the first page. It should not affect other pages in the forum.

                Comment


                • #9
                  I think he's asking if the Apache directive 'CacheNegotiatedDocs' will cause all pages to be reloaded.

                  I believe the answer is yes... I think I'm not sure if graphics get included in that though. The Apache docs aren't very detailed for this sort of thing. Having said that, I think IE will ignore the headers for graphics and use a cached one unless you do an explicit refresh.

                  As far I understand, if you have the default Apache config (CacheNegotiatedDocs commented out), any of the caching settings in vB are irrelevant.

                  Of course, there are also many people running non-Apache servers so it's still a required feature of vB.
                  http://britishexpats.com/ - British expatriate community

                  Comment


                  • #10
                    Originally posted by tubedogg
                    This is only on the forumhome template, meaning the only no-cache is forced is on the first page. It should not affect other pages in the forum.
                    I had turned on the no-cache headers due to the problem with users logging in as other members (from network caching)

                    I would guess that having the no-cache headers on the forumhome page alone would solve this problem without having to force them onto all of the other pages, thereby reducing resource usage. Is this right? Or do I need to leave them turned on?

                    Comment


                    • #11
                      Originally posted by grumpy
                      I would guess that having the no-cache headers on the forumhome page alone would solve this problem without having to force them onto all of the other pages, thereby reducing resource usage. Is this right?
                      Correct.

                      Comment


                      • #12
                        My programmer successfully got rid of the ? marks in the Url's for VB.

                        Reason is because some search engines do not index them.

                        Now, I have found out also that the no-cache headers are in the forumhome by default.

                        Since the Google search engine caches all pages in their index, this tag will tell Google to NOT cache the front page.

                        Google penalizes all pages who have this tag.

                        I guess that getting rid of the ? marks might be for nat?
                        ihelpyou Services
                        http://www.FreeMoneyServices.com
                        http://www.ihelpyouservices.com/forums/

                        Comment


                        • #13
                          Originally posted by ihelpyou
                          My programmer successfully got rid of the ? marks in the Url's for VB.

                          Reason is because some search engines do not index them.

                          Now, I have found out also that the no-cache headers are in the forumhome by default.

                          Since the Google search engine caches all pages in their index, this tag will tell Google to NOT cache the front page.

                          Google penalizes all pages who have this tag.

                          I guess that getting rid of the ? marks might be for nat?
                          Have a look at Overgrow's hack for a search engine friendly archive. it will save you a lot of trouble.
                          http://britishexpats.com/ - British expatriate community

                          Comment


                          • #14
                            Yes, I know. That is what we did.

                            Still, the no-cache headers Have to be on the front page of the forum as per the responses above.
                            ihelpyou Services
                            http://www.FreeMoneyServices.com
                            http://www.ihelpyouservices.com/forums/

                            Comment


                            • #15
                              Originally posted by ihelpyou
                              Yes, I know. That is what we did.

                              Still, the no-cache headers Have to be on the front page of the forum as per the responses above.
                              Yeah, but by using Overgrow's method, the forum home page doesn't actually get submitted to the search engines; the archive does.

                              Not the best solution I agree, it would be better if the real forum could simply be submitted, but....
                              http://britishexpats.com/ - British expatriate community

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X