Announcement

Collapse
No announcement yet.

Need Some Help Here

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Need Some Help Here

    I'm finding that option of remembeing username and password to be and browse boards with cookies to be confusing to the end user and causing problems for my Forums.

    I'm getting reports from some users that when they come to my forums, they keep getting prompted to log in each time they try to post or reply when they are already a member. When I go into their control panels, I find that they have browse the boards with cookies option set to "no" and remember username and password option set to "no"

    Why is this an option and how can I easily set both of these options to "yes" for everyone in the database? Once I figure out how to do this, I plan on eliminating these options out of the templates therefore not giving each member the opportunity of playing with these settings. With all the other Forum software packages I've looked at, vBulletin is the only one that has this.

    This kind of aggravates me a little, because it makes me wonder how many members have returned to my Forums and have experienced this problem and decided to leave....never coming back and not contacting me. I've found that trying to get web site feedback from users is like pulling teeth.
    Last edited by RobAC; Tue 15th May '01, 3:57am.
    Rob

  • #2
    First, remove the appropriate fields from the registration and options templates, then run this query:

    UPDATE user SET cookieuser=1

    Comment


    • #3
      Thanks Kier.

      -Rob
      Rob

      Comment


      • #4
        Kier,

        I've gone into phpMyAdmin, and set cookieuser = 1. Do I still need to run a query? I noticed that if I view members profiles via the admin control panel, settings have not changed.
        Rob

        Comment


        • #5
          That ~should~ be all you need to do... you are referring to the cookie to store username and password, right?

          Comment


          • #6
            Yep. In phpMyAdmin, if you go into User, the field I changed to a default of "1" is "cookieuser". But I still have found several members with settings set to "no" when I view their profiles via the Admin control panel. I've also set adminemail to "1" as well since I want all members to receive any emails by me unless requested otherwise and I still have several members who have settings of "no" in the Admin control panel. That's why I'm a little confused.
            Rob

            Comment


            • #7
              Okay, run these queries:

              Code:
              UPDATE user SET adminemail=1,cookieuser=1
              then this one:

              Code:
              SELECT COUNT(*) AS total FROM user WHERE cookieuser<>1 OR adminemail<>1
              If the second query returns a 'total' value of anything but 0, the first query didn't work for some reason. This should do what you want it to... if it doesn't, let me know.

              Ooh, when I said before that you should removed those fields from the templates, what I actually meant was that you should replace them with this:

              Code:
              <input type="hidden" name="cookieuser" value="1">
              <input type="hidden" name="adminemail" value="1">

              Comment


              • #8
                Kier,

                I've run the queries and everything ran successfully based upon the results you indicated above that I should have received. When I go into the admin panel, it still shows that users are defaulted NOT to use cookies. "NO" is checked off. Unless I go in and manually change each one in the admin control panel, they continue to idicate that members are set not to browse boards with cookies.
                Rob

                Comment


                • #9
                  I think we have some crossed wires here. vBulletin stores two cookies - one which holds the username and password, to enable auto-logging-in, and one to store the sessionhash, preventing it from being passed through the URLs - in the form of s=98797gobbledeegook980834&.....

                  If you want to set the auto-login cookie for all users -

                  UPDATE user SET cookieuser=1

                  If you want to set the sessionhash cookie for all users -

                  UPDATE user SET nosessionhash=1

                  Hope this helps.

                  Comment

                  Loading...
                  Working...
                  X