Announcement

Collapse
No announcement yet.

mySQL Error 1364

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Steve Machol
    replied
    Please note that 2.3.8 is terribly out-of-date. It is possible that the old version of vB is not compatible with your newer versions of PHP and MySQL which were released years after 22.3.8 was written.

    The bottom line is that if you are absolutely sure that you have uploaded the 2.3.8 files correctly and are still getting this error, then this means 2.3.8 cannot be installed on that server with it's current configuration. You will have to either use 3.0.11 or 3.5.3, or perhaps downgrade your PHP and MySQL versions to see if that works with 2.3.8.

    Leave a comment:


  • smc321000
    replied
    Yes, exactly! Thank you Phat Papa Pete! The $$$ is not really the issue, but yes, that's what I'm trying to do.

    To be more specific, we currently have a very old version of vBulletin. In addition, we have another application which we rigged up to authenticate against the same database. Poor design, I know, but it was set up before I got here and now I'm stuck with it. We attempted to upgrade last year, and in fact did successfully upgrade vBulletin, but of course as soon as the structure of the db changed with the vbulletin upgrade, authentication for the other application broke. The guy in charge of this just rolled back to the old version of vBulletin, and now we're back at square one. That guy left, now it's mine. Lucky me.

    We need to uncouple vBulletin and this other app for obvious reasons. So, we want to set up a separate functioning system, completely independent of this other app, running vBulletin and its mySQL db all by itself...the way it should be. Once we've done that, *then* we can upgrade without affecting anything else. I can't simply install the latest version of vBulletin on this new setup because our old db will not work with it.

    Regardless of all that, shouldn't I be able to do a fresh install of version 2.3.8 without getting errors? I assume that version was in use for some time. Taking all of the above out of the picture, if I were a brand new client, and 2.3.8 were the latest version, what would you advise for the error I'm getting?

    Thanks much. I appreciate you guys trying to help. Hopefully, this will clarify the situation.

    Starr

    Leave a comment:


  • Phat Papa Pete
    replied
    Sorry to butt in.

    I think what smc321000 is trying to do is transfer his forum over to a new machine (like what I'm trying to do in the other active thread in this forum). He can't install a fresh installation because he is getting that error stated in his first post. Once he gets past this, he can transfer the database over. THEN he will look into upgrading his version of vBulletin.

    He probably doesn't want to purchase to the latest version right now because of the financial implications. I mean, if I get my vBulletin 2.2.9 working on the new server and transfer everything over successfully, there would be no reason for me to fork out $30 if I have a perfectly fine working version of vBulletin already.

    -Phat Papa Pete

    Leave a comment:


  • Zachery
    replied
    smc321000, you are not making much sense.

    You mean old version of mysql? Which version of mysql are you using?
    Have you tried installing a new verison of vB? If so which one? And if you did what was the error you got.

    Leave a comment:


  • smc321000
    replied
    I can't do a clean install of the version I want to use, because it won't work with the old database.

    Leave a comment:


  • Zachery
    replied
    If you are trying to upgrade, why are you installing?
    Do you have a working vB install?
    If not do a clean install of whatever version you wish to use.

    Leave a comment:


  • smc321000
    replied
    I still have to install the vBulletin application. My db isn't even in the picture yet. The installation is failing when it tries to create the db.

    Leave a comment:


  • Steve Machol
    replied
    Then why are you installing if you weant to use the old database? There is no need to do this. I don't understand what you are trying to do.

    Leave a comment:


  • smc321000
    replied
    But the latest version doesn't work with the old database. And I read in the manual that:

    "If your vBulletin version is older than 2.2.9, you will need to upgrade to at least vBulletin 2.2.9 before you can upgrade to vBulletin 3. "

    We are pre-2.2.9. I assumed that any 2.x version would work with our old db. Is that not the case? Should I install the exact version we are on first?

    Thanks!

    Leave a comment:


  • Steve Machol
    replied
    Originally posted by smc321000
    We are so far behind, have to install an older version before we can install the latest version.
    That's not true. Just install the version you want to run.

    Leave a comment:


  • smc321000
    replied
    Hi Steve,

    We are so far behind, have to install an older version before we can install the latest version. We are also trying to uncouple from another system that authenticates against the same database (not my design!) and so we are starting from scratch on a new machine. Once we get the new machine working with the present db, then we can upgrade to the latest.

    I've had problems with Apache 2.x so I'm using 1.3.34. PHP 4.4.1

    Thanks for replying.

    Starr

    Leave a comment:


  • Steve Machol
    replied
    Which versions of PHP and MySQL are you running. And since this is a fresh install, why 2.3.8?

    Leave a comment:


  • smc321000
    started a topic mySQL Error 1364

    mySQL Error 1364

    Hi All,

    I'm trying to install version 2.3.8 (I know, time to upgrade), and am getting the following during installation:

    <!-- Database error in vBulletin Installer :
    Invalid SQL: INSERT INTO adminutil (title) VALUES ('ids')
    mysql error: Field 'text' doesn't have a default value
    mysql error number: 1364
    Date: Tuesday 20th of December 2005 04:18:39 PM
    Script: /forums/admin/install.php?step=5
    Referer: http://localhost/forums/admin/instal...etdatabase=yes
    -->

    This is a new installation on a new machine. Any ideas?

    Thanks!

Related Topics

Collapse

Working...
X