Announcement

Collapse
No announcement yet.

[Release v2] Who's Online

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • daydreamer
    replied
    Thomas,

    I have been messing with the online file and found only three instantses(sp?) of $loggedins, the rest were $loggedin. So, I renamed them $loggedin. That got rid of the first error.

    Now if we could figure put what a parse error is...

    dd
    Last edited by daydreamer; Sun 3 Jun '01, 6:39am.

    Leave a comment:


  • Thomas P
    replied
    Hi daydreamer

    I just compared my files with yours, they are identical as far as I can see... sorry, I'm lost.

    @tubedog: Does it possibly has something to do with php3?

    greetings from Munich
    -Tom

    P.S.: Unfortunately we have not the best weather at the moment, but maybe in some days will be the right weather for the beergarden

    Leave a comment:


  • daydreamer
    replied
    Tom,

    I am having the exact same problem you are. And have been waiting for a reply now for days. I think there is something wrong with the online file???

    Please let me know if you figure it out.

    PS. I've been to Munich and I love Germany...

    Leave a comment:


  • Thomas P
    replied
    Hmmm, I can't figure it out

    Maybe it's because I'm using PHP3 on the server ?
    thx,
    -Tom

    Leave a comment:


  • Thomas P
    replied
    Hi there,

    I get the following error when browsing the online.php on my server:


    Warning: Variable $loggedins is not an array or string in /home/usr/(...)/forum/online.php on line 29

    Parse error: parse error in /home/usr/(...)/forum/online.php on line 44

    I tried to redo my steps several times - w/o repeating the mysql insert, phpMyAdmin shows me the new 'location' bit in the db, so this seems to be okay...

    Templates are there, online.php is in /forum, session in /admin...

    Am a little bit in the wild in the moment
    Any hints?
    Thanks,
    -Tom

    Leave a comment:


  • daydreamer
    replied
    Thanks for your time Hooper.

    The forum continues to work fine, just the Who's Online doesn't.

    Thanks again....

    dd

    Leave a comment:


  • Hooper
    replied
    Recommendation

    This is what I recommend. First get your forums working properly. Without any hacks. Then backup the files you are going to hack. Then Hack. You should always be able to go back to the working version without the hack within a matter of seconds. The online.php3 file should not keep your forums from working as far as I know. I would suggest you back track and re hack. If this doesn't work after you attempt another hack installation from fresh working vBulliten files, then post again and maybe TubeDogg will come up with some ideas for you.

    Best Wishes,
    Last edited by Hooper; Fri 1 Jun '01, 2:53pm.

    Leave a comment:


  • daydreamer
    replied
    Yea but with my server if you use .php, it will show the code.
    I get the exact same error with the default sessions uploaded. I'm thinking it's in the online.php3 file.

    You can take a look at them at the following links. Maybe someone could take a look at them for me.

    www.dreamsweb.net/php/sessions.php
    www.dreamsweb.net/php/online.php


    Thanks
    dd

    Leave a comment:


  • Hooper
    replied
    Originally posted by daydreamer
    They have to be .php3 on this server...
    This very well may be true. Some do some don't . I have .php4 installed and can use .php,.php3,.etc... I would try it anyhow. Unless of course you would have to rename all of your files. I would suppose this would be the case. If you are sure your hacking is up to par, the only suggestions are what I mentioned. You do need to make sure that you are hacking correctly or you will most definitley get errors. At this time, the WOL hack's line numbers do not match up with the code changes. The changes are 5 or 6 lines down. Make sure you are modifying by code and this bit of info and not by exact line number. If I remember correctly, the only file that gets modified is the sessions.php. You may try your original sessions.php as I mentioned and see if your forums work again, if they do, your problem is in your hacking.

    Btw, I have PHP4 installed and use just the .php extension.

    Leave a comment:


  • daydreamer
    replied
    They have to be .php3 on this server...

    Leave a comment:


  • Hooper
    replied
    Originally posted by daydreamer
    Hooper,
    Thanks for the reply!
    I should have given more info. I get the error when calling "online.php3".

    This is my first hack on the script so my default sessions.php3 file will work. I am usually pretty good at hacking Java so I was very careful in editing the sessions file. I even started from scratch several times and still get the errors.

    Maybe there is someone that can email me a stock sessions with only this hack. [email protected]

    From what you are saying, I have messed something up in the sessions file. hmmm

    Thanks for your time...

    dd
    Welcome,
    Something else you might try is renaming your .php3 extensions to just .php. Then try calling something from the browser.

    It's against your vBulletin license agreement to hand out code, hacked or not. That is out of the question. Sorry.
    Last edited by Hooper; Fri 1 Jun '01, 12:54pm.

    Leave a comment:


  • daydreamer
    replied
    Hooper,
    Thanks for the reply!
    I should have given more info. I get the error when calling "online.php3".

    This is my first hack on the script so my default sessions.php3 file will work. I am usually pretty good at hacking Java so I was very careful in editing the sessions file. I even started from scratch several times and still get the errors.

    Maybe there is someone that can email me a stock sessions with only this hack. [email protected]

    From what you are saying, I have messed something up in the sessions file. hmmm

    Thanks for your time...

    dd

    Leave a comment:


  • Hooper
    replied
    Daydreamer

    Did you backup your sessions.php? If you did you may opt to rename the hacked sessions.php and put your backed up sessions back on the server. If you don't get the error, then you need to go through your hack or rehack.

    Leave a comment:


  • daydreamer
    replied
    Anyone?

    Leave a comment:


  • daydreamer
    replied
    Hello,

    After carefully following the instructions, I get the following error:

    Warning: Variable $loggedins is not an array or string in /home/noc/dre-www/board/online.php3 on line 29

    Parse error: parse error in /home/noc/dre-www/board/online.php3 on line 44


    Thanks
    dd
    Last edited by daydreamer; Fri 1 Jun '01, 4:35am.

    Leave a comment:

widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
Working...
X