Announcement

Collapse
No announcement yet.

[RELEASE] vbSpiderFriend - Search Engine Friendliness

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Thanks guys,

    Streicher, you need to specify which forums are private at the top of index.php. Look for

    $privateForums="|17|18|";

    and put whatever forums in there that should be hidden. Enclose them with |pipes|. Anyone else having these same problems with reloading, etc?


    Brian, my main target here is google. It does fine on other parts of my site where I do these type of query strings. If you do find that some engines are hesitant, let me know or make the change and tell us what you did.
    vB Retro -> See vBulletin 1.1.2 and travel back to the Year 2000!
    Overgrow the Government: The Edge Forums
    presented by Overgrow Marijuana Magazine


    *warning: adult content since vB1.1... now faster than ever!

    Comment


    • #17
      Overgrow,

      I'm interested in the hack but can't seem to get it to work.

      I've followed your instructions but am getting an Error 500 Internal Server Error when I try and run the script.

      I'm running on a Cobalt RAQ4i so I don't know if there is a problem with the .htaccess file and the way the RAQ handles it.

      Any ideas?
      Stephan Whelan CEO DeeperBlue.com
      Fanatical about Freediving, Scuba Diving, Spearfishing and Technical Diving

      Comment


      • #18
        hi..

        great hack..

        but not working for me..

        http://www.nicky.net/foren/archiv/
        cheers
        Nicky
        Facebook Covers | Nicky

        Comment


        • #19
          Nicky:

          Here is your error

          "The requested URL /foren/archiv/11 was not found on this server.
          Additionally, a 404 Not Found
          error was encountered while trying to use an ErrorDocument to handle the request."

          That bottom line is the key.. it says your .htaccess is not pointing to the proper file. Edit the .htaccess and play around with it until you get it right. Sometimes the link has to be ../relative sometimes you can make it absolute /foren/archiv/index.php


          Stephan can you give me a link? I use a Raq4i as well and it works for me. I did have to change the access.conf and put Allow Override ALL in there so htaccess could control the errordocument.
          vB Retro -> See vBulletin 1.1.2 and travel back to the Year 2000!
          Overgrow the Government: The Edge Forums
          presented by Overgrow Marijuana Magazine


          *warning: adult content since vB1.1... now faster than ever!

          Comment


          • #20
            Originally posted by Overgrow
            Stephan can you give me a link? I use a Raq4i as well and it works for me. I did have to change the access.conf and put Allow Override ALL in there so htaccess could control the errordocument.
            http://forums.deeperblue.net/archive/index.php
            Stephan Whelan CEO DeeperBlue.com
            Fanatical about Freediving, Scuba Diving, Spearfishing and Technical Diving

            Comment


            • #21
              Originally posted by Overgrow
              Thanks guys,

              Streicher, you need to specify which forums are private at the top of index.php. Look for

              $privateForums="|17|18|";

              and put whatever forums in there that should be hidden. Enclose them with |pipes|. Anyone else having these same problems with reloading, etc?
              I know that and i have done it already. But it does not work.
              Streicher

              Comment


              • #22
                Originally posted by Streicher


                I know that and i have done it already. But it does not work.
                same here some private forums disappeared but some didn't
                :: Always Back Up Forum Database + Attachments BEFORE upgrading !
                :: Nginx SPDY SSL - World Flags Demo [video results]
                :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

                Comment


                • #23
                  Just finished installing this hack but am having some problems.

                  I'm getting the error:

                  "Fatal error: Call to unsupported or undefined function htmlheader() in /home/keith/webdevforums-www/archive/index.php on line 76"

                  where line 70-78 reads:
                  Code:
                  header("Status: 200 OK"); 
                  
                  //echo "<br>&nbsp;<br>$forumID - $year - $month - $week - $threadID";
                  
                  if (empty($forumID)) {
                  	htmlHeader();
                  	forumList();
                  	exit;
                  You can see the page at http://www.webdevforums.com/archive/

                  Comment


                  • #24
                    Sorry... please forgive my sloppy coding. I'm running a fever and worshipping the porcelain god. You can either replace the forumList function with that below, or download the new zip:

                    Code:
                    function forumList() {
                    
                    	global $db,$baseURL,$privateForums;
                    
                    	echo "Archives<br>";
                    
                    	$privateForums=preg_replace("/^\|/","",$privateForums);
                    	$privateForums=preg_replace("/\|$/","",$privateForums);
                    
                    	$pfs = explode("|",$privateForums);
                    	$whereclause="";
                    	$wherecounter=0;
                    
                    
                    	while($pf=array_shift($pfs)) {
                    		if(ereg("[0-9]",$pf)) {
                    
                    			if($wherecounter==0) {
                    				$whereclause= " WHERE forumid!='$pf'";
                    				$wherecounter++;
                    			} else {
                    				$whereclause .= " AND forumid!='$pf'";
                    			}
                    		}
                    	 }
                    	
                    	
                    
                    	$query = "SELECT title,forumid FROM forum$whereclause ORDER BY forumid ASC";
                    
                    	$data = $db->select($query);
                    
                    	if(!empty($data)) {
                    
                    		while ( list ( $key,$forum ) = each ($data)) {
                    
                    			echo spacer(1)."<a href=\"$baseURL/$forum[forumid]\">$forum[title]</a><br>";
                    		}
                    	}
                    	
                    }
                    Last edited by Overgrow; Tue 1 May '01, 4:19am.
                    vB Retro -> See vBulletin 1.1.2 and travel back to the Year 2000!
                    Overgrow the Government: The Edge Forums
                    presented by Overgrow Marijuana Magazine


                    *warning: adult content since vB1.1... now faster than ever!

                    Comment


                    • #25
                      No clue, coolKeith... Why is your server not capitalizing the function name? See in the code it is htmlHeader() and your server says htmlheader()... Look down in the very bottom of the index.php and you will see the function htmlHeader()... it is there and working. All I can say is try and download it again. If that still doesn't work, change the function name to lower case and see if that helps.
                      vB Retro -> See vBulletin 1.1.2 and travel back to the Year 2000!
                      Overgrow the Government: The Edge Forums
                      presented by Overgrow Marijuana Magazine


                      *warning: adult content since vB1.1... now faster than ever!

                      Comment


                      • #26
                        Thanks Overgrow. It works fine.

                        And i have find out that only forums with id <10 (1-9) makes a reload of index.php, when clicking on the link.
                        Streicher

                        Comment


                        • #27
                          Originally posted by Overgrow

                          Anyone else having these same problems with reloading, etc?
                          .
                          I have sorted it now it was a problem within .htaccess
                          Last edited by Peteruk; Thu 3 May '01, 10:54am.

                          Comment


                          • #28
                            Just one problem (I hope ) it all loads up ok no errors or anything but when you click on a forum it loads up but where it should look like below

                            May
                            week1
                            week2
                            week3
                            week4

                            It just displays a page like below

                            Archives
                            Competition
                            2001




                            vbSpiderFriend by ~shabang~ of Overgrow

                            any idea what the problem is no doubt something I've done

                            Comment


                            • #29
                              Here I go again I have sorted the above and the problem was the date is in MM/DD/YYYY I thought I saw DD/MM/YYYY

                              Comment


                              • #30
                                Sorry.. typical N.American-centric time code eh! But that's the way that the php function strtotime is written...

                                I'm glad people have this working. Now let's hear the success stories in a few months when spiders actually list our posts.
                                vB Retro -> See vBulletin 1.1.2 and travel back to the Year 2000!
                                Overgrow the Government: The Edge Forums
                                presented by Overgrow Marijuana Magazine


                                *warning: adult content since vB1.1... now faster than ever!

                                Comment

                                widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                                Working...
                                X