Announcement

Collapse
No announcement yet.

Backup downloads file.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Backup downloads file.

    Something a little strange. RC2 "do backp" asks me to download a file. Backup.php. I don't believe this to be right. Any suggestions?
    Last edited by Hooper; Sat 28th Apr '01, 5:12pm.

  • #2
    That is right. There are now two backup options you can do that or dump the information into a sql file in your admin directory...
    ...

    Comment


    • #3
      What seems strange about it is that I looked at the file and it seems to be the file backup script. Not a backup. It's like prompting for a download of the actual backup script. RC1 didn't do this.

      Comment


      • #4
        Polite Bump.................


        This is not working correctly for me. I am getting prompted to download a file called backup.php when I go to "Do Backup". I am not getting a dump. Would someone give me an idea of what might have happened? It worked in RC1.

        Thank You.
        Last edited by Hooper; Sat 28th Apr '01, 5:13pm.

        Comment


        • #5
          What browser are you using? Your server should be running the file, not sending it for download.

          Comment


          • #6
            Hi Tube,

            Yes, exactly the server should be running the file, not asking me to download it. Browser isn't the problem. IE5.5, Netscrape 6 and Neoplanet 5 all do the same thing.

            I have done upgrades all along and really don't want to do a fresh install. Upgrade from beta 5, RC1,RC2. RC1 was working correctly. RC2 is the last ver to give me this. Most likely something simple, but I don't know the prog well enough to figure this out.

            Thank You,
            Last edited by Hooper; Sat 28th Apr '01, 6:30pm.

            Comment


            • #7
              GimmeTech,

              Just out of curiousity what are the file permissions on your backup.php file? Are they different than admin.php for example?

              I know that some people say file permissions aren't important, but as I understand it that's not the case if your host is running PHP as CGI.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                *.PHP set to 755.

                Here is what I just got when I tried again with netscape. It don't prompt me to download the file but....

                DROP TABLE IF EXISTS access;
                CREATE TABLE access (
                userid int(10) unsigned NOT NULL,
                forumid smallint(5) unsigned NOT NULL,
                accessmask smallint(5) unsigned NOT NULL,
                KEY userid (userid,forumid)
                );




                DROP TABLE IF EXISTS adminlog;
                CREATE TABLE adminlog (
                adminlogid int(10) unsigned NOT NULL auto_increment,
                userid int(10) unsigned NOT NULL,
                dateline int(10) unsigned NOT NULL,
                script char(20) NOT NULL,
                action char(20) NOT NULL,
                extrainfo char(200) NOT NULL,
                PRIMARY KEY (adminlogid..........and so on............

                ok.... Now Iv'e backed up with the "do backup" a couple of times. I have no idea what to even expect to get now. Any Ideas?
                Last edited by Hooper; Sat 28th Apr '01, 6:56pm.

                Comment


                • #9
                  Database tables to include in backup: "do backup"
                  doesn't want to run the backup.php.

                  Save data to file on server:
                  works great.

                  CSV Dump of data:
                  doesn't want to run the backup.php.


                  Dunno.

                  Comment


                  • #10
                    Actually what you just said makes it sound like it is working exactly as it supposed to. CSV dump is supposed to dump to screen, and you save it to your HD from there. Do Backup under the first section is the exact same way. The only option that actually puts a file on your server is the second one.

                    Comment


                    • #11
                      Hi tube,

                      It doesn't dump it to the screen though. It prompts to download the darn backup.php.

                      Only in Netscape does it show what I have above. IE5.5 for all but save to server prompts for a download of the backup.php.
                      This didn't happen in RC1. I haven't had any problems with the browser with anything else, But maybe IE5.5 is getting flaky on me. Any other ideas?
                      Last edited by Hooper; Sat 28th Apr '01, 7:12pm.

                      Comment


                      • #12
                        Have you actually downloaded the backup.php file to confirm that your server is indeed sending the actual PHP code?

                        Comment


                        • #13
                          Hi Ed,

                          I reupped the backup.php to the server and over wrote it hoping that might take care of it. Still doesn't work. Again, in Netscape it prints the file to screen, but it isn't what I remember seeing in RC1. In IE5.5 it just prompts for a download of the backup.php.
                          I'm not exactly what you were asking, but This is what I have done so far and I still get the same result.

                          Thank You,

                          Comment


                          • #14
                            It's supposed to prompt you to download a file. We don't send too many headers, so it's possible IE is just ignoring the Content-disposition header we are sending.

                            I'm just saying you're up in arms about a filename -- if you download the backup and open it in a text editor, you'll see it's actually a backup of your data.

                            [edit]Hmm... bad headers actually. They'll be changed for the next release[/edit]
                            Last edited by Mike Sullivan; Sat 28th Apr '01, 7:55pm.

                            Comment


                            • #15
                              Ok, I hope you are not editing your post while I am typing this. I just can't wait to see that you have... .

                              I believe that this is supposed to print to screen. Just talked to Smachol and he told me that he is getting nothing like I am getting. He gets a backup printed to screen. I don't. I get prompted to download the file. Has nothing to do with the name of the file. Has to do with why isn't it doing what it did before. I am just trying to figure out if this is a browser problem (doubt it), something maybe got corrupted, or if I need a reinstall.

                              Being I am just learning this fabulous proggie. I'm really expecting to hear that it is something that I have wrong on my end. Maybe even what It may be.


                              Oh, an edit

                              "[edit]Hmm... bad headers actually. They'll be changed for the next release[/edit]"

                              Would you mind elaborating a little on this.

                              Thank You,
                              Last edited by Hooper; Sat 28th Apr '01, 8:05pm.

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X