Announcement

Collapse
No announcement yet.

RC1 upgrade error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • RC1 upgrade error

    I am upgrading from 1.1.6 to RC1,and i am getting this error in step2:

    <!-- Database error in vBulletin Upgrade: Invalid SQL: CREATE TABLE privatemessage (
    privatemessageid int(10) unsigned DEFAULT '0' NOT NULL auto_increment,
    folderid smallint(6) DEFAULT '0' NOT NULL,
    userid int(10) unsigned DEFAULT '0' NOT NULL,
    touserid int(10) unsigned DEFAULT '0' NOT NULL,
    fromuserid int(10) unsigned DEFAULT '0' NOT NULL,
    title varchar(250) NOT NULL,
    message mediumtext NOT NULL,
    dateline int(10) unsigned DEFAULT '0' NOT NULL,
    showsignature smallint(6) DEFAULT '0' NOT NULL,
    iconid smallint(5) unsigned DEFAULT '0' NOT NULL,
    messageread smallint(6) DEFAULT '0' NOT NULL,
    readtime INT (10) UNSIGNED DEFAULT '0' not null,
    receipt SMALLINT (6) UNSIGNED DEFAULT '0' not null,
    deleteprompt SMALLINT (6) UNSIGNED DEFAULT '0' not null,
    multiplerecipients SMALLINT (6) UNSIGNED DEFAULT '0' not null,
    PRIMARY KEY (privatemessageid),
    KEY userid (userid)
    )
    mysql error number: 1044
    -------

    and yes I did changed the new config.php
    How can I solve this error?

  • #2
    you'll need to install VBB 2.0 beta 1-5 first...
    then you can install RC1
    :D:):p:rolleyes::cool:

    Comment


    • #3
      Thanks rickjansen105

      I went back to install 1-5 then to go with RC1 ,but the same error still exists !!

      Any idea?

      Comment


      • #4
        What script are you running?
        Translations provided by Google.

        Wayne Luke
        The Rabid Badger - a vBulletin Cloud demonstration site.
        vBulletin 5 API - Full / Mobile
        Vote for your favorite feature requests and the bugs you want to see fixed.

        Comment


        • #5
          what do you mean wluke?

          I am running 1.1.6 now,but the upgrade to RC1 gave me the above error

          Comment


          • #6
            What script are you running to perform the upgrade?

            Unless you have an older version of MySQL the code you posted shouldn't cause an error.
            Translations provided by Google.

            Wayne Luke
            The Rabid Badger - a vBulletin Cloud demonstration site.
            vBulletin 5 API - Full / Mobile
            Vote for your favorite feature requests and the bugs you want to see fixed.

            Comment


            • #7
              1.1.6

              I contacted my host for the MySql version!!

              Comment


              • #8
                Originally posted by theGAME
                1.1.6

                I contacted my host for the MySql version!!
                No. you don't understand.

                What upgrade script did you use?
                There are 6 upgrade scripts, upgrade1.php, upgrade2.php ..... and upgrade6.php.

                Comment


                • #9
                  Oh I am sorry,didnt have enough sleep recently

                  I ran upgrade1.php as in the Upgrade Instructions:

                  >From 1.1.x:

                  Upload all the files, then run the upgrade1.php scrint in the admin area. When you are done, be sure to delete install1.php and all the upgradex.php scripts.

                  Comment


                  • #10
                    Ok the host said that they tested the SQL line and it worked in a test database.

                    The real problem could be here,It's not authorizing to the database correctly.

                    mysql error: Access denied for user: '*********' to database '*******'

                    I checked back with the User and Pass and and they were CORRECT!

                    Any idea??? please help!

                    Comment


                    • #11
                      im not bery good at this, bu try going into the config file and just double check that the, database/server name thingy iis the name of the server (mines my name) and that the password is correct

                      Comment


                      • #12
                        I checked the config.php many times,and everything is correct man!!

                        I am stuck in step2 now for 3 days,and my forum is closed,do I have to email '[email protected]' to get a follow up support or what?!!

                        Comment


                        • #13
                          Did you verify that your information for logging into the database was correct with your host?

                          We cannot provide you with that information.

                          If you are upgrading, then you should have a backup of your old database from 1.1.X and should be able to restore it and get your forums back online. When installing something such as this on critical data you should always make a backup. I also recommend installing a trial run on a duplicate of your database not the live version.
                          Translations provided by Google.

                          Wayne Luke
                          The Rabid Badger - a vBulletin Cloud demonstration site.
                          vBulletin 5 API - Full / Mobile
                          Vote for your favorite feature requests and the bugs you want to see fixed.

                          Comment


                          • #14
                            The information in "config.php" is correct,I am positive or else I won't be able to go to step2,I will be getting error before even step1.

                            It's something in the "privatemessage" I dont know whats with it!!

                            Comment


                            • #15
                              Ok I opened "db_mysql.php" and noticed this:

                              var $server = "localhost";
                              var $user = "root";
                              var $password = "";

                              I thought "root" should be replaced with $dbusername as well as the password.Is this blocking the authoriziation??

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X