Announcement

Collapse
No announcement yet.

How do I get the email function to work?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • How do I get the email function to work?

    When people sign up to my forum they never get there confirmation email. I did a test to myself and the email never came threw either. Its not being sent to the junk mail folder either, I checked. I know I can disable the confirmation email function but I would rather not. Where do I need to go to get my email working on the site? Thanks for any help.

  • #2
    First try this:

    Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Enable "-f" Parameter -> Yes

    Then try the vB email functions. If it still doesn't work, then try the email diagnostics in the Admin CP and report back the results:

    Admin CP -> Imports & Maintenance -> Diagnostics -> Email


    vB uses PHP's mail() function for all its email and uses the SMTP server specified in php.ini. If PHP and the mail server are configured correctly then email will work.

    If after all this you still don't get the email then this is a server and/or mailbox issue. You will need to view the mail logs on the server to see what happened to those emails. Once vB sends it to PHP it's in the hands of the server. If you are on a shared server you may need to ask your host to look through the logs for you.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      Originally posted by Steve Machol
      First try this:

      Admin CP -> vBulletin Options -> Server Settings and Optimization Options -> Enable "-f" Parameter -> Yes

      Then try the vB email functions. If it still doesn't work, then try the email diagnostics in the Admin CP and report back the results:

      Admin CP -> Imports & Maintenance -> Diagnostics -> Email


      vB uses PHP's mail() function for all its email and uses the SMTP server specified in php.ini. If PHP and the mail server are configured correctly then email will work.

      If after all this you still don't get the email then this is a server and/or mailbox issue. You will need to view the mail logs on the server to see what happened to those emails. Once vB sends it to PHP it's in the hands of the server. If you are on a shared server you may need to ask your host to look through the logs for you.
      I dont have those options. Im running version 2.3 so there is no "Server Settings and Optimization" under the VB CP. Let me know what I should do. Thanks

      Comment


      • #4
        Sorry, not too many people are still using vB2. Unfortunately you do not have this option in vB2. You will need to view the mail logs on the server to see what happened to those emails. Once vB sends it to PHP it's in the hands of the server. If you are on a shared server you may need to ask your host to look through the logs for you.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by Steve Machol
          Sorry, not too many people are still using vB2. Unfortunately you do not have this option in vB2. You will need to view the mail logs on the server to see what happened to those emails. Once vB sends it to PHP it's in the hands of the server. If you are on a shared server you may need to ask your host to look through the logs for you.
          Thanks. Could you tell me which email address the board uses to send out the emails? Is it the same email that I have listed under my webmaster email section? The email I have listed as the webmaster's email is a cyber-rights.net email. Could that be the problem or no? Thanks for any help.

          Comment


          • #6
            vB uses the webmaster's email address as the From address. On some servers this needs to be the same domain as your forums.
            Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
            Change CKEditor Colors to Match Style (for 4.1.4 and above)

            Steve Machol Photography


            Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


            Comment

            widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
            Working...
            X