Announcement

Collapse
No announcement yet.

safe mode.. how to upload?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • safe mode.. how to upload?

    seems that this doesn't work right in 2.0 beta 4.1

    I have little knowledge of PHP, but tried some things to fix it... no luck

    this is what I get:

    Code:
    Warning: SAFE MODE Restriction in effect. The script whose uid is 16422 is not allowed to access /var/tmp//phpqvcmL5 owned by uid 0 in /usr/home/sites/veritas/web/admin/avatar.php on line 33
    it's a bit strange: /var/tmp//phpqvcmL5
    I got a dir: tmp with chmod 777 in my root, but that is not /var/tmp/ more like /web/tmp/
    after tmp there is a double slash.. this cant be right, in the Path to image box I filled in: /tmp, so where does that slash come from?
    and what about that last part... is that just the result from the errormessage and does it not belong after tmp//

    Help me please !

  • #2
    Safe mode basically neuters uploading. I'll look into the code to see if I missed the workaround there, but the workaround may still not work on the server. The easiest way to get rid of errors like that is to get rid of safe mode, or change the upload_tmp_dir to something your script would own (like ./tmp for example).

    Comment


    • #3
      yeah.. thought about something like that... but how do I change it?

      Comment

      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
      Working...
      X