Announcement

Collapse
No announcement yet.

installation error!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • installation error!

    I am getting this error before I even install it... Please help me fix it, i have installed it before, but i had screwed it up so i had to rinstall, and now it wont work:


    Warning: mysql_connect(): Access denied for user 'piper_'@'localhost' (using password: YES) in /home/piper/public_html/admin/db_mysql.php on line 40




    There seems to have been a slight problem with the database.
    Please try again by pressing the refresh button in your browser.

    An E-Mail has been dispatched to our Technical Staff, who you can also contact if the problem persists.

    We apologise for any inconvenience.



  • #2
    This error means either:

    1. One or more of the following is wrong in your config.php file:

    $servername (except in rare cases, this should almost always be left as 'localhost' or '127.0.0.1')
    $dbusername
    $dbpassword
    $dbname

    If you are unsure of what the appropriate values are then you will need to ask your web host.

    2. Or that this db user is not assigned to that database or does not have permission to access MySQL to create or access a database. You may need to first manually create the database and assign the db user to it. Since each web host is different, if you do not know how to do this then contact your web host for help.

    3. Or you are running MySQL 4.1.x. As of MySQL 4.1.X there is a new password hashing system. PHP4 does not have builtin support for it as of yet, however PHP5 does. In order for your old PHP4 MySQL clients to be able to connect to the MySQL 4.1.X database you need to set an OLD_PASSWORD. You should be able to run the following Query to make it possible for PHP4 to access the MySQL 4.1.X database.

    SET PASSWORD FOR 'username'@'localhost' = OLD_PASSWORD('password');

    More info is here:
    http://dev.mysql.com/doc/mysql/en/password-hashing.html
    http://dev.mysql.com/doc/mysql/en/up...-from-4-0.html
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      is it possible to just upgrade to php 5?

      Comment


      • #4
        Of course, but that may have nothing to do with this error.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment

        widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
        Working...
        X