Announcement

Collapse
No announcement yet.

Database Error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Database Error

    I just put my Forums back on line after yesterday's failed upgrade attempt and now I'm getting a new database error:

    Database error in vBulletin: Invalid SQL: INSERT INTO user (userid,username,password,email,styleid,parentemail,coppauser,homepage,icq,aim,yahoo,signa ture,adminemail,showemail,invisible,usertitle,joindate,cookieuser,daysprune,lastvisit,last activity,usergroupid,timezoneoffset,emailnotification,receivepm,emailonpm,showsignatures,b irthday,maxposts,startofweek,ipaddress,pmpopup,referrerid,nosessionhash) VALUES (NULL,'wt2ga','norwin','[email protected]','0','','0','http://','','','','','0','1','0','New Member','986490274','1','2','986490274','986490274','2','-5','1','1','1','0','1948-1-18','-1','1','205.188.200.52','1','0','0')
    mysql error: Unknown column 'showsignatures' in 'field list'
    mysql error number: 1054
    Date: Thursday 05th of April 2001 01:04:34 PM
    Script: /forums/register.php
    Referer: http://www.corvetteactioncenter.com/forums/register.php

    I have a feeling it's time to go back to 1.1.6........
    Rob

  • #2
    It appears you ran sort of through the upgrade script and then went back to beta 3 files?

    Anyway do this

    ALTER TABLE user CHANGE options showsignatures SMALLINT (6) DEFAULT '1' not null

    Comment


    • #3
      Actually, all the beta 4 files have been uploaded. I tried running the script the second time after the first time, but it gives me a message stating that the script was already run and any further changes will have to be manually added.

      Where do I make the change you state above?
      Rob

      Comment


      • #4
        Beta 4 files would have not have generated that error. You need to verify that your register.php is the version from beta 4 if you claim that beta 4 caused the above error. You would only execute the query I gave you if you are trying to go back to beta 3 which I would not do. At what step did your upgrade stop ? PM your server login details and I will fix your problems (though it may be an hour or 2 before I can get to it).

        Comment


        • #5
          The first time I started the upgrade, the last files that I was uploading were the main .php files (register.php etc.) Somewhere along the way, I lost FTP access during the upload which I've been fighting against all week.

          I didn't realize this occurred and ran the upgrade script. I ran through the entire upgrade without any problems. When I went into the Forums to inspect the changes, the only thing that had changed was the version number at the bottom of the Forums. The vB Code option in posts/replies and other options were not there. Upon further inspection, I realized that approximately 5 of the main files uploaded. The rest were still from beta 3.

          I re-uploaded all the files insuring that everything transferred over and tried running the script again. As soon as I started it, I receive a message stating that it appears I have already run the script and the upgrade cannot continue.....any further changes will have to be made manually.

          At that point, I deleted all the beta 4 files, reinstalled the beta 3 files and started over from scratch. I tried running the script again, and abandoned it after I received the message again.

          You have a PM. Thanks for taking the time to look into this Freddie.
          Last edited by RobAC; Thu 5 Apr '01, 10:01am.
          Rob

          Comment


          • #6
            Rob try it out now.

            You did have beta 3 files on your forum. You will need to make the needed changes to some templates though. Refer to the beta 4 announcement for the list of changed templates. If you have modified any of those you need to either revert them or select view original and compare the changes to your modified versions.

            Things such as birthdays, maxusers ever, etc won't show up until you do.

            Comment


            • #7
              Freddie,

              Thanks for the help. I really appreciate it.
              The vB Code and Smilies are now showing up in the newreply/newthread pages.

              I'll go through the templates and compare the changes that I need to make.
              Rob

              Comment


              • #8
                Missing Template??

                Freddie,

                According to your list of templates changed:

                - forumdisplay_loggedinusers - Added max users ever variables.

                I have no template called forumdisplay_loggedinusers

                I've also run a template search and it only returns the forumhome template. Any ideas?
                Rob

                Comment

                Related Topics

                Collapse

                Working...
                X