Announcement

Collapse
No announcement yet.

Avatar uploads broken!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Avatar uploads broken!

    Awhile ago installed a avatar hack, that allowed avatars to be put into catergories etc. I forget the name of the hack, but its pretty popuilar. But somewhere along the way, the hack broke and I don't really know how to uninstall it.

    Well I upgraded my vbulletin all the way up to 2.3.6 and now when you try and change your avatar I get this mysql error (sorry about the overly large screen cap, but it redirects and it was the only way to get the error).

    Any help would be great! Would upgrading to vb3 get rid of the errors? Ideally I would like to be able to remove the hack I installed and have it a clean unhacked board.


  • #2
    Upload the phpinfo.php file from the 'extras' directory of the zip file to your forums directory. Then post the URL here. This will help us troubleshoot the problem.
    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
    Change CKEditor Colors to Match Style (for 4.1.4 and above)

    Steve Machol Photography


    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


    Comment


    • #3
      http://www.violetprison.com/board/phpinfo.php

      There you go! Thanks for the help!

      Comment


      • #4
        You need to make sure your server has a directory named:

        /www/tmp

        ...and that it is chmod'd to 777. Once you do this uploads will work.
        Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
        Change CKEditor Colors to Match Style (for 4.1.4 and above)

        Steve Machol Photography


        Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


        Comment


        • #5
          Originally posted by Steve Machol
          You need to make sure your server has a directory named:

          /www/tmp

          ...and that it is chmod'd to 777. Once you do this uploads will work.
          Righ on! I will do that now! Thanks so much!

          Comment


          • #6
            Ack, ok I have a problem in the fact that its looking for a www folder when the folder on the server is htdocs. The board was moved accross servers a time ago, and the www folder was the webside folder.

            How do I go about changing it from www to htdocs?

            Comment


            • #7
              The actualy directory this must be according to your php.ini file is:

              /www/tmp

              This cannot be a subdirectory of your htdocs directory. This need to the the full and complete path to this directory on the server. You will need to have root access to the server to create this directory.

              The only other option is to edit php.ini and change the upload_tmp_dir setting to point to a real directory that is chmod'd to 777. This also requires root access and restarting Apache.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                But he way the this hosting account is set up is that its

                /htdocs/tmp

                As on the old account it was set up as

                /www/tmp

                Is there now way to change it so the board looks for the /htdocs/tmp instead of /www/tmp?

                I don't have root access so I am abit stuck as what I am supposed to do to fix the error!

                Comment


                • #9
                  Also the page redirection has no stopped working! :-/

                  Comment


                  • #10
                    Originally posted by SimonB
                    But he way the this hosting account is set up is that its

                    /htdocs/tmp

                    As on the old account it was set up as

                    /www/tmp

                    Is there now way to change it so the board looks for the /htdocs/tmp instead of /www/tmp?

                    I don't have root access so I am abit stuck as what I am supposed to do to fix the error!
                    As I said this requires editing the php.ini file and restarting Apache. You need root access to the server to do this. I suggest contacting your host abotu this.
                    Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
                    Change CKEditor Colors to Match Style (for 4.1.4 and above)

                    Steve Machol Photography


                    Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


                    Comment


                    • #11
                      Ok, I will get in contact with them. They should be understand as their support forum is a vbulletin board.

                      Comment

                      widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                      Working...
                      X