Announcement

Collapse
No announcement yet.

PHP 4.3.10 - strange problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • PHP 4.3.10 - strange problem

    Main page (index.php) just showed standard vB2 style default look and all the profile buttons - very strange. I could access /admin just the same but I wasn't able to access any threads/forums.

    I suspect there is some sort of weird quirk between mysql 4.1.8 and php 4.3.10 with regards to vB2...

    I went back to php 4.3.8 and everything was back to normal.

    Will investigate further - (I still have this 'buggy' setup running on another IP just to test things out - <<removed temporarily>>)
    Last edited by Swamper; Fri 24th Dec '04, 11:47am.

  • #2
    You might want to point your hosting provider to this link: http://www.vbulletin.com/forum/showthread.php?t=123531 and request them to investigate if their php & zend optimizer are both up to date. You're the first to report an issue back for version 2 of vBulletin.

    Comment


    • #3
      I'm the host I disabled mmcache and I'm not using zend - tried both ways with mmcache re-compiled/enabled and disabled and got the same result.

      Edit: Maybe I should add that I duplicated this behaviour under Apache 2.0.52 and Apache 1.3.31
      Last edited by Swamper; Fri 24th Dec '04, 1:39am.

      Comment


      • #4
        I'll point this out to the developers and we will have a look at it. As version 3.0.3 reports no errors with PHP 4.3.10 I suggest to upgrade your 2.3.5 to 3.0.3 if possible.

        Comment


        • #5
          Just wanted to stick my oar in here to say that we've seen no problems with vB 2.3.5 under PHP 4.3.10 in our tests...

          Comment


          • #6
            I unzipped vb 2.3.5 and used my current DB and I have the same problem - now I'm trying to set up a new DB and test it from scratch but it dies on creation:

            CREATE TABLE adminlog (
            adminlogid int(10) unsigned DEFAULT '0' NOT NULL auto_increment,
            userid int(10) unsigned DEFAULT '0' NOT NULL,
            dateline int(10) unsigned DEFAULT '0' NOT NULL,
            script char(20) NOT NULL,
            action char(20) NOT NULL,
            extrainfo char(200) NOT NULL,
            ipaddress VARCHAR(15) NOT NULL,
            PRIMARY KEY (adminlogid)
            )
            ERROR 1067: Invalid default value for 'adminlogid'

            Weird - I'm going to recompile mysql and see if that solves anything.

            Comment


            • #7
              ERROR 1067: Invalid default value for 'adminlogid'

              This is the second report I've seen with this specific error concerning vB2 and the latest versions on MySQL. Methinks MySQL did something to break the install script for vB2.
              Steve Machol, former vBulletin Customer Support Manager (and NOT retired!)
              Change CKEditor Colors to Match Style (for 4.1.4 and above)

              Steve Machol Photography


              Mankind is the only creature smart enough to know its own history, and dumb enough to ignore it.


              Comment


              • #8
                I got the same error (as mentioned in first post) when attempting to use PHP 5.0.3 with Apache 2.0.52/1.3.31

                For now I'll stick to apache 1.3.31 + php 4.3.8

                Comment

                Loading...
                Working...
                X