Announcement

Collapse
No announcement yet.

[RELEASE v2] Last XX Posts on non-vB page

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #61
    can this be included on a separate domain site on the same server ?

    i want to include the threads using SSI from my forums on my site at eva2000.com
    :: Always Back Up Forum Database + Attachments BEFORE upgrading !
    :: Nginx SPDY SSL - World Flags Demo [video results]
    :: vBulletin hacked forums: Clean Up Guide for VPS/Dedicated hosting users [ vbulletin.com blog summary ]

    Comment


    • #62
      hmm...I don't see why not. It may take a bit of playing to get it right, but...

      You could change
      Code:
      require("$path/config.php");
      to
      Code:
      require("/full/path/to/eva2000/admin/config.php");
      in last10.php, then put last10.php and last10config.php into a directory in the other domain's area.

      It should work. (Should being the key word there )

      Comment


      • #63
        The changes sound great, now how bout adding 'em to the zip? (its still version 0.1.0 in post #1)

        Comment


        • #64
          No it's not...

          Comment


          • #65
            Odd. I must be having some funky caching probs in MSIE. I can't get the new file even after clearing the cache and restarting. I fired up NN and pulled down the current zip....thanks, tubedogg.

            Comment


            • #66
              Amazing job tubedogg!
              The update is excellent, well done man!

              Comment


              • #67
                tube this is a great hack! 5 stars!

                One thing I caught though, when I tried to create the same format as your last two images/examples, everyhting went great, however when I enabled the smilies ($showicon=1), they would not show. Am I missing something?

                Comment


                • #68
                  Tubedogg, you rule!

                  I made a few formatting changes. Take a look.....
                  www.bsboard.com/recent.php


                  Also, another suggestion....

                  How about adding a field in the user options where they can choose how many recnt posts to dispaly? I have mine set to show 30, but some people may wanna see less, while others may wanna see more.


                  Thanks again for the awesome work. (they need this feature in the gold version)

                  Comment


                  • #69
                    Van: Looks good! As for your suggestion, I'm not sure. I might look into it, but I might also try a separate hack for use as you are using it. I have some ideas for that one from the UBB hack that I (and apparently you) used to use so we'll see what happens.

                    Claypots: Whoops! I screwed up. I'll post the new version (1.0.1) in the first post in this thread. I overlooked something. Duh!

                    Comment


                    • #70
                      Thanks Tube, I like it very much!
                      -----------
                      Posts show server time (ET), while my forum is GMT +1.

                      How can I show the same time of the forum?
                      -----------
                      If I set to show the message, at very beginning of the table I see:
                      0
                      10
                      0
                      30
                      0 (If I set 5 posts)

                      0
                      10
                      0
                      30
                      0
                      20 (If I set 6 posts)

                      7 times 0 (if I set 7 posts) etc.

                      "0" if there is not icon and the other numbers are the icons number.

                      what could it be?
                      Last edited by julius; Sat 28 Apr '01, 6:34am.

                      Comment


                      • #71
                        The numbers are something that was accidentally left in after testing. Sorry...I have released v1.0.2 in the first post to correct this.

                        I will look into the times for the future. However, you do know that any unregistered/logged-out visitors see the time on your board as GMT, right? I believe that's the closest I can get without going into member cookies, which is something I don't want to do with this script.

                        Comment


                        • #72
                          Thx Tubedogg, it's perfect now.

                          For all (registered, guests and unlogged) it would be fine just something like server time +- n hours (or GMT +- n hours), without using cookies.

                          If in this way there are some problem with showing the correct date, it could be let it off.
                          Last edited by julius; Sun 29 Apr '01, 7:30am.

                          Comment


                          • #73
                            Works great (except): When I put a forum number(s) in either (only 1 of the two) include or exclude forums, "can't select info" .

                            If I leave these blank, display's with no problem. Help!

                            Excellent hack.

                            Comment


                            • #74
                              Odd...I can't reproduce that problem. Make sure you are only putting numbers and commas into those two variables, and separating the numbers with commas. So it might look like:
                              Code:
                              $includeforums = "3,4,5,6";

                              Comment


                              • #75
                                That's exactly how I did it.
                                Would it be a good idea (or possible) to have the script automatically exclude private forums?

                                Comment

                                Related Topics

                                Collapse

                                Working...
                                X