Announcement

Collapse
No announcement yet.

[release vb2.0b3] VB2ICQ - (Custom status-img and sent icq-message)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [release vb2.0b3] VB2ICQ - (Custom status-img and sent icq-message)

    HACK: VB2ICQ

    DESCRIPTION: This small-hack enables you to define custom icq-status images and sent icq-messages to members

    EXAMPLE: http://forever.feyenoordnet.nl/forum...d=56&styleid=3

    NOTE: Enabling this feature may result in slower loading of the icq-statuses of your members
    NOTE2: If the icq-server is down, clear.gif is loaded

    INSTRUCTIONS:

    1) Upload "disabled.gif", "offline.gif", "online.gif" to your images directory
    2) Upload "icq.inc.php", "icqmessage.php", "icqstatus.php", "javascript.js" to your vbulletin root-folder
    3) Open your "postbit"-template and change <!-- $ post[icqicon] --> to $post[icqicon]
    4) Open your "headinclude"-template and add: <script language="Javascript" src="javascript.js" type="text/javascript"></script>
    5) Edit your "icq"-template and modify it with the content of "icq.txt"
    6) Create 3 new templates: "icq_message_sent", "icq_message_not_sent" and "icq_send_message" and insert the content of the appropiate .txt files in it

    That's it! Enjoy

    Credits to: F.Kranen - http://www.odsync.net/ for creating icq.inc.php
    Last edited by Mas*Mind; Mon 16 Apr '01, 3:29pm.

  • #2
    Nice hack man!

    Change your link tho!
    http://forever.feyenoordnet.nl/forum...hp?threadid=20

    Change the & to a ?

    snyx
    MSN: [email protected] | MAIL: [email protected] | FOLIO: mholman.com

    Comment


    • #3
      done..

      Comment


      • #4
        Nice and cool idea..!
        Will test it in a few hours
        The Sisko
        SciFi-Forum.de

        Comment


        • #5
          Note that there may be the same problem as on this issue here

          Until there is a solution for this, you just have to bear with it I'm affraid

          Comment


          • #6
            If you wanna avoid that you can just use <img src="http://online.mirabilis.com/scripts/online.dll?icq=$userinfo[icq]&img=5" alt="$userinfo[username]'s ICQ status" border=0> in the icq-template instead of <img src="icqstatus.php?uin=$userinfo[icq]&path={ imagesfolder }" alt="$userinfo[icq]" border="0" width="20" height="14"> and use the default icq-img

            Comment


            • #7
              msgs

              installed and tried this the messages dont seem to send from it any ideas it says the msg has been sent but thats it i tried sending to my own icq and my web aware is enabled ?

              Comment


              • #8
                Cool hack but i wont use it but i love your icons

                Comment


                • #9
                  Re: msgs

                  Originally posted by pestilence
                  installed and tried this the messages dont seem to send from it any ideas it says the msg has been sent but thats it i tried sending to my own icq and my web aware is enabled ?
                  I don't really follow you (hint: use dots ) but do you mean the messages aren't sent?

                  Originally posted by jojo85
                  Cool hack but i wont use it but i love your icons
                  Thanks

                  Comment


                  • #10
                    what did you change exactly?

                    Comment


                    • #11
                      another language?

                      all my templates i cut and pasted are in another language-do u have english version?

                      Comment


                      • #12
                        Originally posted by insdel
                        I have changed in icq.inc.php

                        line 44:

                        if ($len == 105)$ret = $ICQ_STATUS_ONLINE;

                        to

                        if ($len == 96)$ret = $ICQ_STATUS_ONLINE;

                        line 45:

                        if ($len == 18) $ret = $ICQ_STATUS_DISABLED;

                        to

                        if ($len == 83) $ret = $ICQ_STATUS_DISABLED;

                        line 46:

                        if ($len == 0) $ret = $ICQ_STATUS_OFFLINE;

                        to

                        if ($len == 1) $ret = $ICQ_STATUS_OFFLINE;

                        I realized that most indicators are shown up correctly but others not. I'm not sure if there's a problem with icq's dll itself or if icq.inc.php doesn't work correctly
                        What do you mean with 'most indicators'? If you're using the standard icq indicators (ie: set 1, set 2, set 3 etc..) then you shouldn't using this script, then you can directly link to icq.

                        This script is only meant to display custom (self made) images. So in this case it should always be '&img=1' because otherwise indeed the above values won't work.

                        Comment


                        • #13
                          hmm...strange, it works very well for me

                          Comment


                          • #14
                            how did you decide which new values you's use?

                            Comment


                            • #15
                              Hi!

                              After the "send"-Button, i only get a white window.

                              Thats all.

                              Any Idea ?



                              Sascha

                              Comment

                              widgetinstance 262 (Related Topics) skipped due to lack of content & hide_module_if_empty option.
                              Working...
                              X